overflow:auto scroll bar does not appear when contents exceed div size

RESOLVED DUPLICATE of bug 114706

Status

()

RESOLVED DUPLICATE of bug 114706
17 years ago
16 years ago

People

(Reporter: hoks, Assigned: john)

Tracking

({css2, testcase})

Trunk
mozilla1.1alpha
x86
Windows 2000
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.7+)
Gecko/20020101
BuildID:    2002010103

The page above has a DIV that has the overflow control on auto. When the page is
first loaded, scrollbar did not appear for the DIV, it is obvious that there are
more content than displayed in the DIV, because of the incomplete sentences.
But if the browser window is resized vertically, the scrollbar appears.
Scrollbar does not appear if window is resized horizontally.


Reproducible: Always
Steps to Reproduce:
1. Open page in URL
2. Check content in the middle of page.
3. Resize window height, or maximize window to make scrollbar appear


Actual Results:  Scrollbar appears only after the window is resized

Expected Results:  Scrollbar should appear when contents exceeds DIV's size.
->Layout
Assignee: dbaron → attinasi
Component: Style System → Layout
QA Contact: ian → petersen
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can reproduce the problem with 2002012803 build on WINNT.
Reassigning to John
Assignee: attinasi → jkeiser
Target Milestone: --- → mozilla1.1

Comment 3

17 years ago
Verified with 2002012814 and 0.9.7 on Linux.  Resizing it horizontally or
vertically temporarially fixes the problem, however.

Comment 4

17 years ago
Created attachment 68488 [details]
CSS2 Stylesheet with rule for FIXED div with OVERFLOW property

Comment 5

17 years ago
Created attachment 68491 [details]
Test Case for overflow:auto bug.

Uses 68488 attachment for styling.  The behavior described above should be
evident.

Comment 6

17 years ago
Created attachment 71292 [details]
Workaround for this problem (ugly hack!)

This bug bit me several times already :( 

I think it's an important one, because the overflow/div combination is the only
(as far as I can tell) way in CSS to create pages that function like the old
frameset/iframe layouts.

The workaround fiddles with the horizontal window size (-1 px, +1px), forcing a
redraw. It's an ugly hack, so if anyone has a better way, please let me know.

Comment 7

17 years ago
My workaround is too enclose the entire body of the div in a single-celled 
table.  The width of the table will not extend past the right margin.  Also an 
ugly hack, but I think it's better than javascript.

Comment 8

17 years ago
This bug is very bad as there is no real satisfactory work around. It makes it
almost impossible to create a page using only divs.
Keywords: css2

Comment 9

17 years ago
Sometimes luck comes our way... 

I tested all testcases today on RC1 (Xft) on Linux and I can't reproduce the bug
anymore. Seems it magically fixed itself. I noticed some other reflow/layout
bugs being fixed lately, so it seems that somewhere along the line another bug
was fixed that was causing this particular problem. 

Can someone confirm and mark the bug as 'Resolved'?

Comment 10

16 years ago
Also WorksForMe using FizzillaCFM/2002071208.
Keywords: testcase

Comment 11

16 years ago
Created attachment 94082 [details]
overflow:auto fails to add scrollbar when browser window is smaller than content

Comment 12

16 years ago
wfm moz 20021001508 win98

*** This bug has been marked as a duplicate of 114706 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.