Closed Bug 1186765 Opened 6 years ago Closed 5 years ago

Scrolling is janky on specific page when zoomed in

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Swarnava, Unassigned)

References

()

Details

Go to: http://gerrit.aospal.com/#/c/1155/4/packages/SystemUI/src/com/android/systemui/BatteryMeterView.java: 

try to zoom in/out and scroll down/up

Result: 

the browser become unresponsive sometime.
Version: Firefox 39 → Firefox 40
Reproduced with today's Fennec Nightly on a Sony Xperia Z3 running Android 5.0.2. Chrome 43 seems to perform much better although I still notice some slight jank.
Version: Firefox 40 → Trunk
Snorp, what can we do about this?
Flags: needinfo?(snorp)
This another instance of synchronous subframe scrolling biting us.
Depends on: apz-fennec
Flags: needinfo?(snorp)
I think the URL is invalid now, it goes to some hosting company's website instead of (presumably) a java code file.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
hmm, here is a new  url http://review.cyanogenmod.org/#/c/122385/1/doze/src/com/cyanogenmod/settings/device/MotoDozeService.java

you can check this on any gerrit code review repo
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
This is improved now with APZ, but still seems to be pretty janky -- especially when you are zoomed in.
Agreed, when zoomed it appears to jank when a repaint comes in, or something. Not entirely sure, we will need to investigate. I'm marking this as blocking APZ riding the trains on Fennec just so we make sure we look into what's going on before we ship it.
No longer depends on: apz-fennec
Summary: Fennec is becoming laggy on long webpage → Scrolling is janky on specific page when zoomed in
Status: REOPENED → NEW
Bug 1241917 will probably help here.
Depends on: 1241917
I don't see a lot of jank when APZ-scrolling on this anymore. I do see other issues however. It looks like there are actually two scrolling subframes which are "linked", so scrolling one will scroll the other. This "linking" is a scroll-linked effect which is laggy with APZ and makes it look janky. We have bug 1246290 as a backup plan for that issue, if it becomes too bad.

On top of that, this is a CodeMirror code window, which has it's own set of problems (bug 1249090) with respect to checkerboarding. It also had jankiness issues (bug 1239615, fixed by bug 1243589). When zooming in it looks like there's still some checkerboard-like behaviour going on, which we can track with bug 1249090.

Basically, the jank seems to be fixed, so I'm going to close this bug. If there's more issues that are not covered by the above-referenced bugs, please file a new bug. Thanks!
Status: NEW → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.