[regression] First-party cookies are not recognized in iframes if third-party cookies set to >Never< accept

RESOLVED WORKSFORME

Status

()

Core
Networking: Cookies
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: matthias koplenig, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Since rev: d317a93e5161, cookies seem to not be set in iframes if accepting third-party cookies is set to >Never< accept them, even if they(iframe + parent) are on the same domain.

I'm seeing this in our work CMS(lots of iframes) and my online-banking website.


might be a regression from bug 1173523.
the regression-range seems to be:

good: 15155971639c
bad: d317a93e5161

Comment 1

3 years ago
Do you have time to check this?
Flags: needinfo?(michael)

Comment 2

3 years ago
(In reply to Josh Matthews [:jdm] from comment #1)
> Do you have time to check this?

I'm looking into it, I don't think that the permissions manager changes would affect this, but I can't think of anything else which has touched the cookie code recently.

Comment 3

3 years ago
I don't think I can reproduce the bug, visiting http://mystor.github.io/mozilla-bug-1186868-testcase/ on my local build of nightly will (after a second) show the cookie value I set in both iframes. Could you help me produce a working test case?
Flags: needinfo?(michael) → needinfo?(mozilla)

Updated

3 years ago
Keywords: testcase-wanted
(Reporter)

Comment 4

3 years ago
i guess the easiest way would be like this.

login here: http://metasieben.org/webEdition/
l: demo
p: demo

with third-party cookies on >Never< accept: 3rdparty.png
with third-party cookies on >From visited<: visited.png
Flags: needinfo?(mozilla)
(Reporter)

Comment 5

3 years ago
Created attachment 8638077 [details]
3rdparty.png
(Reporter)

Comment 6

3 years ago
Created attachment 8638078 [details]
visited.png
(Reporter)

Comment 7

3 years ago
just updated to the latest Nightly(rev: 1f77b78797d6) and it seems to be working again.
i'm at a loss, how is this even possible?

Comment 8

3 years ago
(In reply to matthias koplenig from comment #7)
> just updated to the latest Nightly(rev: 1f77b78797d6) and it seems to be
> working again.
> i'm at a loss, how is this even possible?

Looks like it was fixed (which might be why I couldn't reproduce). I'm going to close this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.