App installation button is labeled “Open app” even though the app was not installed on a non-certs FF OS device

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: valentina.peleskei, Unassigned)

Tracking

Avenir
2015-07-28
Unspecified
Gonk (Firefox OS)
Points:
---

Details

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Load MP-dev on your FF OS 2.0 device (without certs set)
2. Search for a packaged app (i.e. newNewnew)
3. Try to install the app

Expected results:
The app cannot be installed. The message “App install error: INVALID_SIGNATURE” is displayed. The installation button remains blue and labeled “Install for free”.

Actual message.
The app is not installed but the installation buttons is green and labeled “Open app” after a page refresh. If clicked, nothing happens.

Notes/Issues:
Verified on FF OS 2.0(Flame). Issue is reproducing on MP-dev and MP-stage.
Ashes ID: 345cd
Specific to -dev and -stage. WONTFIX due to not being consumer-facing.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.