Mouseover navigation menus disappear 1/2 way

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: stephend, Assigned: joki)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

URL: http://www.msnbc.com

Summary: Mouseover navigation menus disappear 1/2 way 
Build ID: 2002-01-07-03, Windows 2000 **Commercial** build.

This only affects the commercial build, but that is because their sniffer code
doesn't correctly detect Moz (by using the .family property).

Steps to Reproduce:

1.  Load http://www.msnbc.com
2.  Mouseover 'Technology'.
3.  Somewhere 1/2 way through the menu (traversing down it), the DHTML menu will
simply disappear.

Expected Results:

Menu appears, and it open until you mouse away from it.

Actual Results:

The dynamic menu disappears near 1/2 way through traversing it.
'Technology' isn't a special category, the rest of the categories behave the
same way also.
Keywords: nsbeta1
Seems like the image on the bottom of the page is the problem, when you mose
over that in a menu (i.e. when the image is behind the menu) the menu goes away.
Over to DOM Events.

Any investigation on what's special about the image, or something close to the
image would be greatly appreciated.
Assignee: jst → joki
Component: DOM Style → DOM Events
Keywords: mozilla0.9.8, mozilla0.9.9
QA Contact: ian → vladimire
I see this on my linux build, too, marking OS/Plat -> All.
OS: Windows 2000 → All
Hardware: PC → All
OS: All → Windows 2000
Hardware: All → PC
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

17 years ago
It appears that the problem may be related to the fact that the img which causes
the submenu to close has a usemap.

Their menu code http://msnbc.com/tools/nm/nmjs02.js uses Event.target for
Mozilla and window.event.srcElement for IE. target can be any Node not just an
Element for us. Did our behavior with respect to setting target on image maps
change since 094?

Note that this problem does not appear in Mozilla 0.9.4.2 with a NS6 ua string
but does appear in Mozilla 2002-01-11-03/win2k with a NS6 ua string.
Keywords: regression

Comment 5

17 years ago
Adding nsbeta1 keyword to all regressions so they *get some love* and attention.
This also occurs on
http://www.nbcolympics.com/x/f/frame.htm?u=/news/nbcomain_front.asp

If we ship another milestone with this bug we should be ashamed...

Comment 7

17 years ago
This bug seems to also cause some major problems on the official Olympics 
website - bug 120934.
worksforme (this was fixed by bug 120934).
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 9

17 years ago
verifying on 2002-01-29-03-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.