[Contacts] Unable to open contacts application

VERIFIED FIXED

Status

()

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: arcturus, Assigned: mrbkap)

Tracking

({regression, smoketest})

unspecified
regression, smoketest
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox42 fixed, b2g-master verified)

Details

(Whiteboard: [dogfood-blocker][fromAutomation])

Attachments

(1 attachment)

With the following setup:

Gaia-Rev        8d4d0bb88f61e72554ab68e51282f08e1be536b6
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2ddec2dedced
Build-ID        20150723010205
Version         42.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150527.043015
FW-Date         Wed May 27 04:30:24 EDT 2015
Bootloader      L1TC000118D0

We see in the logcat the following error:

/Gecko   ( 2947): IPDL protocol error: Handler for SetCookieString returned error code
I/Gecko   ( 2947):
I/Gecko   ( 2947): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x3E0003,name=PCookieService::Msg_SetCookieString) Processing error: message was deserialized, but the handler returned false (indicating failure)
I/Gecko   ( 2947):
I/Gecko   ( 2947): [Parent 2947] WARNING: waitpid failed pid:3568 errno:10: file /builds/slave/b2g_m-cen_flm-kk_eng_ntly-0000/build/gecko/ipc/chromium/src/base/process_util_posix.cc, line 267
I/Gecko   ( 2947): [Parent 2947] WARNING: pipe error (273): Connection reset by peer: file /builds/slave/b2g_m-cen_flm-kk_eng_ntly-0000/build/gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 459
I/Gecko   ( 2947):
I/Gecko   ( 2947): ###!!! [Parent][MessageChannel] Error: (msgtype=0x200081,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
I/Gecko   ( 2947):

Seems that is an error related to the cookies.

In contacts we use a cookie to get/store the value for ordering the contacts list. Is one of the first things that we do, it's in the critical path, and seems that's the reason why the app is failing to start.

Opening against contact, but asking for a regression window, we think the error could be in gecko side.
Keywords: regressionwindow-wanted
Confirmed with Francisco, the issue always happens.

[Blocking Requested - why for this release]: Smoketest blocker.
blocking-b2g: --- → 2.5+
status-b2g-master: --- → affected
Keywords: regression, smoketest
Maybe somehow related with the landing of bug 1165263?
QA Contact: jmercado
The changes for Bug 1139953 seem to have caused this issue.

Fx Team-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150721221151
Gaia: 84c3bf622e211046d905803b34de5d331761f22d
Gecko: e05387dd6b04
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150722002851
Gaia: 84c3bf622e211046d905803b34de5d331761f22d
Gecko: ce485b16a186
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 84c3bf622e211046d905803b34de5d331761f22d
Gecko: ce485b16a186

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 84c3bf622e211046d905803b34de5d331761f22d
Gecko: e05387dd6b04

Gecko Pushlog: http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=e05387dd6b04&tochange=ce485b16a186
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Blake, can you take a look at this please? Looks like the landing for bug 1139953 might be the cause here. This is a smoke test blocker. Can we get this landing backed out?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(mrbkap)
Whiteboard: [dogfood-blocker]
Created attachment 8638261 [details] [diff] [review]
Patch

I landed this on inbound with r=gwagner. Josh, would you mind doing a post-facto review? The problem is that the hostURI on b2g was an app:// URI and we were failing to create the channel.

While I was here, I made failure to create the dummy channel non-fatal, since it really isn't important to pass the 'are we private browsing' in for this one case.
Attachment #8638261 - Flags: review?(josh)
Assignee: nobody → mrbkap
Flags: needinfo?(mrbkap)
Status: NEW → ASSIGNED

Updated

3 years ago
Attachment #8638261 - Flags: review?(josh) → review+
Duplicate of this bug: 1187274
https://hg.mozilla.org/mozilla-central/rev/6c2d68d7625d
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Duplicate of this bug: 1187102

Comment 10

3 years ago
I've updated to latest and am pleased to say it's fixed for me too.
This issue is verified fixed in the latest Spark 2.5 build.
Contacts app opens and functions correctly.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150725011637
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: d3228c82badd
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: affected → verified
Flags: needinfo?(onelson)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(onelson)

Updated

3 years ago
Blocks: 1187430
Component: Gaia::Contacts → Networking: Cookies
Product: Firefox OS → Core
Moving the bug to the component where the regression came from.
The report sent on the same day state these tests caught the issue:
* test_add_new_contact
* test_edit_contact
* test_sms_contact
* test_add_photo_to_contact
Whiteboard: [dogfood-blocker] → [dogfood-blocker][fromAutomation]
You need to log in before you can comment on or make changes to this bug.