Last Comment Bug 118696 - inappropriate Accept request header field-values
: inappropriate Accept request header field-values
Status: RESOLVED DUPLICATE of bug 82526
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Darin Fisher
: Tom Everingham
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-08 00:38 PST by mnot
Modified: 2002-01-08 07:09 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description mnot 2002-01-08 00:38:42 PST
Mozilla generates a static Accept header

Accept: text/xml, application/xml, application/xhtml+xml, text/html;q=0.9,
image/png, image/jpeg, image/gif;q=0.2, text/plain;q=0.8, text/css, */*;q=0.1

no matter what kind of request it is making. For requests generated from img
tags, it's inappropriate to send 'application/xhtml+xml', 'text/css' and the like. 

Suggest that:
- for img requests (and similar, e.g., css stylesheet fetching, javascript
inclusion, etc.), a context-specific Accept header be generated
- for generic requests (from the browser bar or those from a links), the default
Accept header be sent, *except* that image/* types be sent with a slightly lower
q value. Mozilla is a hypertext browser, after all, and if there are both html
and jpg representations of a resource, it should prefer the html, all other
things equal.
- when an a link contains a 'type' parameter, that media type should be added to
the Accept header with the highest q value.
Comment 1 mnot 2002-01-08 01:19:19 PST
Also, Mozilla shouldn't send */* at all. 

See: 
  http://www.w3.org/TR/cuap#cp-http-accept
Comment 2 Christopher Hoess (gone) 2002-01-08 07:09:59 PST
*/* is only harmful if the supported possibilities have not been exhausted, IMO.Anyway, this seems to be more or less covered by bug 82526.

*** This bug has been marked as a duplicate of 82526 ***

Note You need to log in before you can comment on or make changes to this bug.