No graphical way to display e10s data in perfherder compare view

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jmaher, Assigned: wlach)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
looking at two revisions which I know has e10s data:
https://treeherder.mozilla.org/perf.html#/compare?originalProject=mozilla-central&originalRevision=8d262d1d0ae5&newProject=mozilla-central&newRevision=15155971639c

I do not see any reference to e10s.  We have a url option &e10s=1 which doesn't work right now, but we should make a checkbox or link to avoid the magic url param discovery thing.
Just pushed a change that makes "&e10s=1" work. You can see this on stage:

https://treeherder.allizom.org/perf.html#/compare?originalProject=mozilla-central&originalRevision=8d262d1d0ae5&newProject=mozilla-central&newRevision=15155971639c&e10s=1

Is there any reason we shouldn't just show everything by default? I'd rather do that than have a confusing checkbox that only actually works for some branches.
Flags: needinfo?(jmaher)
(Reporter)

Comment 2

3 years ago
I vote for showing everything by default.  Although it will make the list a LOT longer.
Flags: needinfo?(jmaher)
As an alternative, I suppose if we find e10s results we could show a banner in the actual compare view with two options:

[ Show everything ] [ Show e10s only ] [ Show only non-e10s ]

Thoughts?
(Reporter)

Comment 4

3 years ago
ideally compare view will be redone to show a lot of simple filters:
* e10s +-
* pgo +-
* ignoreNoData
* ignore minor changes

and maybe more.
Created attachment 8638154 [details]
Screen Shot 2015-07-23 at 5.32.50 PM.png

Maybe just a row of filter elements to show/hide the different options?

See a screenshot for details.

CC'ing :bwinton and :avih for second and third opinions.
Attachment #8638154 - Flags: feedback?(jmaher)
Attachment #8638154 - Flags: feedback?(bwinton)
Attachment #8638154 - Flags: feedback?(avihpit)
(Reporter)

Comment 6

3 years ago
Comment on attachment 8638154 [details]
Screen Shot 2015-07-23 at 5.32.50 PM.png

I like this stuff!
Attachment #8638154 - Flags: feedback?(jmaher) → feedback+

Comment 7

3 years ago
Comment on attachment 8638154 [details]
Screen Shot 2015-07-23 at 5.32.50 PM.png

I _think_ right now e10s is only PGO, so it should probably be: opt / pgo / pgo(e10s) ?

If in the future we'd also have opt(e10s), then we could add that too.
Attachment #8638154 - Flags: feedback?(avihpit) → feedback-
Comment on attachment 8638154 [details]
Screen Shot 2015-07-23 at 5.32.50 PM.png

In general, I'm not a fan of options, but I think I need more context here before saying one way or the other.  (Grab me some time tomorrow?)
Attachment #8638154 - Flags: feedback?(bwinton)
tracking-e10s: --- → +
tracking-e10s: + → ---
See Also: → bug 1210505

Updated

3 years ago
tracking-e10s: --- → +
Updating the description to show the actual problem.

This keeps on biting people so I'm going to address it this week, when I return from holiday tomorrow anyway.
Assignee: nobody → wlachance
tracking-e10s: + → ---
Summary: perfherder compare view doesn't show e10s data → No graphical way to display e10s data in perfherder compare view
Picking this up again.
tracking-e10s: - → ---
tracking-e10s: --- → -
Created attachment 8674993 [details] [review]
Always show e10s data in compare view

This PR should fix the immediate issue while we figure out a better interface for filtering, etc.
tracking-e10s: - → ---
Attachment #8674993 - Flags: review?(jmaher)
(Reporter)

Comment 12

3 years ago
Comment on attachment 8674993 [details] [review]
Always show e10s data in compare view

great, step1 - show all tests!
Attachment #8674993 - Flags: review?(jmaher) → review+

Comment 13

3 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/626678ab83f5555e8822f105ed79d6eeae9d3e73
Bug 1187000 - Always show e10s data in compare view

We can add some kind of a filtering interface later, but until that's
ready it's confusing to just not display it unless people specify
a magic flag (e10s=1).
Let's resolve this. I filed bug 1215617 to deal with the issue of creating a proper filtering interface for the compare view.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1210505
Blocks: 1222849
You need to log in before you can comment on or make changes to this bug.