Unnecessary additional history entry if frameset is resized

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Roland Unger, Assigned: Radha on family leave (not reading bugmail))

Tracking

(Blocks: 1 bug)

Trunk
Future
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If a frameset is resized by JavaScript DOM command like
document.getElementsByTagName("frameset")[0].setAttribute("cols", "180,*")
a new entry in the history is added although no URI or cursor positions
are changed.
Proposal: Do not add a new history entry. Otherwiise it is difficult
to navigate back in history.

It seems that after the resizing as mentioned above also URI parameters
are missing like "abc" in http://anything.com?abc.
session history
Assignee: blaker → radha
Component: History: Global → History: Session

Comment 2

16 years ago
related to 109252?
(Reporter)

Comment 3

16 years ago
Bug 118703 is not the same like 109252, but it is actually related to it.
At www.t-online.de I found at the frameset definition page the following
tag (simplified):

<frameset rows="73,*" ...
 onload="top.document.getElementById('frameset1').rows='65,*'">

i.e., after first loading new frame widths are assigned; but in this
case a really reloading, not only a redrawing occurs. The problem of
T-online is, that a resizing occurs in any case.

And after this redrawing (actually reloading) a second history entry
occurs.

Concernings bug 118703, my intention is the following: I want to support
user configuration (frame width via cookie) using
setAttribute("cols", "180,*"). In my case I could not see (test from
a hard disk) if a reloading occurs, I think a redrawing (without a
new history entry) is sufficient.

Comment 4

16 years ago
i think this bug should be a dupl (or a 
"blocked by" bug) of bug 48422
(Reporter)

Comment 5

16 years ago
If the additional history entry is a consequence of re-loading of all children 
(frameset windows) then this bug is really a duplicate of bug 48422.
This bug  should get resolved when 48422 is fixed. 
Status: UNCONFIRMED → ASSIGNED
Depends on: 48422
Ever confirmed: true
Target Milestone: --- → Future
Please retest... I cannot reproduce this bug either before or after fixing bug
48422...

Updated

16 years ago
Blocks: 59387
No reaply in years, can'r reproduce, so...
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.