test_settings_change_keyboard_language.py: "TimeoutException: Timed out after 10.3 seconds"

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: oliverthor, Assigned: Martijn Wargers (zombie))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Description:
test_settings_change_keyboard_language is failing consistently in the non-smoke report, after accessing the 'settings => keyboard' menu and tapping the control for adding an additional keyboard language. The UI screen for 'Select Keyboards' opens, but the test fails to act afterwards.

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/181/HTML_Report/
* http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc.bitbar/146/HTML_Report/

Repro Steps:
1) Update phone to 20150723010205
2) Open the Settings app
3) Open the Keyboard menu
4) Tap button 'Select Keyboards' to add additional keyboards
5) Observe screen

Actual:
Test fails to act after reaching 'Select Keyboards' screen

Expected: 
Test selects a new keyboard, and at "Settings:Keyboards" identifies that a keyboard has been successfully added.

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@2/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@2/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_change_keyboard_language.py", line 27, in test_change_keyboard_language_settings
add_more_keyboards.select_language(u'Espa\u00F1ol')
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@2/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/keyboard.py", line 56, in select_language
expected.element_present(*language_locator))
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@2/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/wait.py", line 143, in until
cause=last_exc)
TimeoutException: TimeoutException: Timed out after 10.3 seconds

Environmental Variables:
Device firmware (base) 	L1TC000118D0
Device firmware (date) 	23 Jul 2015 08:24:55
Device firmware (incremental) 	eng.cltbld.20150723.042443
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	f30ecc97
Device uptime 	0 days 0 hours 2 minutes 17 seconds
Gaia date 	22 Jul 2015 18:44:09
Gaia revision 	f04fdbfa1943
Gecko build 	20150723010205
Gecko revision 	2ddec2dedced
Gecko version 	42.0a1

Reproducible manually: No

Repro frequency: 5/5
(Assignee)

Updated

3 years ago
QA Contact: martijn.martijn
Created attachment 8638509 [details] [review]
[gaia] mwargers:1187066 > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8638509 [details] [review]
[gaia] mwargers:1187066 > mozilla-b2g:master

Apparently this started happening with the move to gaia-checkbox.
I'm not an xpath wizard, fwiw, but I think this looks goodish.
I tried to use setTimeout in execute_script, but couldn't get it to work.

With this, the test is still failing, but that's because the Contacts app fails to launch currently, see bug 1186920.
Attachment #8638509 - Flags: review?(npark)
Attachment #8638509 - Flags: review?(jlorenzo)
Comment on attachment 8638509 [details] [review]
[gaia] mwargers:1187066 > mozilla-b2g:master

LGTM!
Attachment #8638509 - Flags: review?(jlorenzo) → review+
Comment on attachment 8638509 [details] [review]
[gaia] mwargers:1187066 > mozilla-b2g:master

looks okay to me too
Attachment #8638509 - Flags: review?(npark) → review+
(Assignee)

Comment 5

3 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/e9a940b23af342e29cfee2ea803fe3f0c154d5d9
Assignee: nobody → martijn.martijn
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.