[gtk3] [mulet] REFTEST TEST-UNEXPECTED-FAIL | file:///home/worker/build/tests/reftest/tests/layout/reftests/xul/tree-row-outline-1.xul | image comparison (==), max difference: 229, number of differing pixels: 323

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: glandium, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
See https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/j9mtESLERJ2lDSMF-Sb4Jw/0/public/logs/live_backing.log
Blocks: 1193807
Keywords: regression
OS: Unspecified → Linux
(Reporter)

Updated

2 years ago
No longer blocks: 1193807
(Reporter)

Comment 1

2 years ago
The timeouts are, somehow, gone. There's now a perma-orange:
http://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/WUvZtBT1TMuf84CLFL3SQw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

There is a one pixel difference in the vertical position of the second line of text in the test case. The weird thing is that it only happens on mulet builds, not on browser builds for the same changeset.
Summary: [gtk3] Reftest timeouts on mulet builds → [gtk3] [mulet] REFTEST TEST-UNEXPECTED-FAIL | file:///home/worker/build/tests/reftest/tests/layout/reftests/xul/tree-row-outline-1.xul | image comparison (==), max difference: 229, number of differing pixels: 323
This is already annotated with "skip-if((B2G&&browserIsRemote)||Mulet)", so I don't know why this is running.  It should be fails-if(Mulet) if not intermittent.

I wonder whether Mulet and browser builds use different fonts.
(Reporter)

Comment 3

2 years ago
The problem is that the reftest harness doesn't handle multiple things correctly (bug 720684). Fixed in https://hg.mozilla.org/integration/mozilla-inbound/rev/f37c01f7c064
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.