[Settings] Wi-fi is not fully disabled in sleep mode when "Wi-fi sleep" is turned on in Settings.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
8 months ago

People

(Reporter: NicholasN, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8638189 [details]
adb_logcat_wifi

Description:
The user connects to a wi-fi hotspot and switches on "Wi-fi" sleep. Next, they lock the device or let the display time out. An ADB logcat is pulled, and the hotspot is disabled. In the logcat, it appears that the device continues to scan for a wi-fi connection, long after the device has gone to sleep.


Repro Steps:
1) Update an Aries to 20150723134401
2) On another device, create a wi-fi hotspot.
3) On the Aries, go to Settings > Wi-fi and connect to the hotspot.
4) Toggle Wi-fi Sleep.
5) Enable USB Storage in Settings.
6) In Settings > Developer, check Wi-Fi Output in ADB
7) Lock the Aries device.
8) Disable the hotspot on the second device.
9) Observe output of ADB logcat.


Actual:
Device continues to scan for wi-fi connection while in sleep mode.


Expected:
Wi-fi is fully disabled while device is in sleep if Wi-Fi Sleep is toggled.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150723134401
Gaia: aa1698251e86c820c50c045b0a3ff65fd6b0eee7
Gecko: eee2d49d055c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 4/4
See attached: video clip, logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8638197 [details]
logcat_Flame2.2
(Reporter)

Comment 2

3 years ago
Issue also occurs on Flame 2.5

Flame 2.5

Actual:
Device continues to scan for wi-fi connection while in sleep mode.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150723010205
Gaia: f04fdbfa1943dddeab8ecd1299a76ab56e590d00
Gecko: 2ddec2dedced
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Flame 2.2

Actual:

Cannot determine if wi-fi is connected in sleep mode. ADB logcat throws a cycle of errors and the phone restarts.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150723002503
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: d8326043baec
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Whiteboard: [2.5-Daily-Testing][Spark]
Seems like this feature isn't working in 2.5 and 2.2 behavior is a lot worse with an OS restart.

NI component owner to take a look.

Also adding qawanted to verify the 2.2 behavior.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(nhirata.bugzilla)
Keywords: qawanted
(Reporter)

Comment 4

3 years ago
Tested this on another 2.2 device, and the restart issue didn't repro. However it did keep searching for a wi-fi connection. I also branch checked 2.1 and the issue does not reproduce there because wi-fi sleep is not an option.

Flame 2.2

Actual:
Device continues to scan for wi-fi connection while in sleep mode.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150723002503
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: d8326043baec
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Flame 2.1

Actual Result:

Wi-fi sleep is not an option in settings.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150723001203
Gaia: 9a1a6ab6a00646abf19f8371cd419c78783ef7f5
Gecko: 55edd9de0b57
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
status-b2g-v2.2: --- → affected
Keywords: qawanted
Henry, can you take a look please?
Flags: needinfo?(nhirata.bugzilla) → needinfo?(hchang)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> Henry, can you take a look please?

Is the USB cabled is plugged? Only when the screen is off and the usb cable is 
unplugged will the wifi be disabled after a while [1].

Thanks :)

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/wifi.js#L211
Flags: needinfo?(hchang)
Hi Nicholas,
Can you update based on comment #6?
Flags: needinfo?(nnelson)
Hi Kevin,
Can you help to find someone to update this based on comment #6?
Flags: needinfo?(ktucker)
(Reporter)

Comment 9

3 years ago
I tested this by initiating download of a 1 gb file. I put the device to sleep at 26%, woke it 5 minutes later, and it was at 34%. I put it back to sleep and checked about fifteen minutes later, and the progress was at 88%. Based on these results, it seems like wi-fi is not turned off, and each time I woke the device it appeared that the wifi was not attempting to reconnect based on the status bar icon.
Flags: needinfo?(nnelson)
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
Tested with phone connected to wifi, wifi sleep enabled, initiated a 1GB file download, turned off the screen. The only variable here is whether or not the phone was plugged in.

- When phone was plugged in and I woke the screen 15 min later:
Download was still going at 8%.

- When phone was unplugged and I woke the screen 15 min later:
On lockscreen it says 'Download failed 5 min ago' and I visually saw the device reconnect to wifi upon waking screen. Which means wifi appears to have stopped at ~10 min after screen off.


I think it should be made clear to the users that Wifi Sleep will only take effect when the phone is unplugged. Currently the description of Wifi-Sleep in Settings > Wifi only says 'Enable to automatically turn off Wi-Fi during sleep to save battery power' - which does not mention anything about unplugging.

Tested on:
Device: Aries 2.5
BuildID: 20150921142023
Gaia: 2d370fa35c1a0ee2a637e3772c0843586a5f96c9
Gecko: fcef8ded82219c89298b4e376cfbdfba79a1d35a
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)

Comment 11

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.