Talos tests are broken on beta (mac and linux, not windows)

RESOLVED FIXED

Status

Testing
Talos
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
We get this on mac & linux for the last few hours:

15:06:35     INFO -  Running test tresize:
15:06:35     INFO -  		Started Thu, 23 Jul 2015 15:06:35
15:06:35     INFO -  DEBUG : operating with platform_type : mac_
15:06:35     INFO -  DEBUG : created profile
15:06:35     INFO -  DEBUG : command line: /builds/slave/test/build/application/Nightly.app/Contents/MacOS/firefox -foreground -profile /var/folders/_9/t28c0ng56mb25xlsk8sq_vj400000w/T/tmpKh3loC/profile http://localhost/getInfo.html
15:06:44     INFO -  INFO : Could not find __metrics(.*)__metrics in browser_log: browser_output.txt
15:06:44     INFO -  INFO : Raw results:FATAL ERROR: Non-local network connections are disabled and a connection attempt to tiles.services.mozilla.com (52.25.215.0) was made.
15:06:44     INFO -  You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
15:06:44     INFO -  INFO : Initialization of new profile failed
15:06:44     INFO -  INFO : FATAL ERROR: Non-local network connections are disabled and a connection attempt to tiles.services.mozilla.com (52.25.215.0) was made.
15:06:44     INFO -  You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
15:06:44     INFO -  DEBUG : Terminating: 1679

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-beta-macosx64/1437623601/mozilla-beta_yosemite_test-chromez-bm107-tests1-macosx-build7.txt.gz

Looks like regression from bug 1180762, where mozprofile went from 0.23 to 0.24. Perhaps related to this:

diff -ru mozprofile-0.23/mozprofile/prefs.py mozprofile-0.24/mozprofile/prefs.py
--- mozprofile-0.23/mozprofile/prefs.py	2015-01-08 02:30:51.000000000 +1300
+++ mozprofile-0.24/mozprofile/prefs.py	2015-06-12 17:41:16.000000000 +1200
@@ -164,8 +164,6 @@
                               to str.format to interpolate preference values.
         """
 
-        comment = re.compile('/\*([^*]|[\r\n]|(\*+([^*/]|[\r\n])))*\*+/', re.MULTILINE)
-
         marker = '##//' # magical marker
         lines = [i.strip() for i in mozfile.load(path).readlines() if i.strip()]
         _lines = []
@@ -176,7 +174,6 @@
                 line = line.replace('//', marker)
             _lines.append(line)
         string = '\n'.join(_lines)
-        string = re.sub(comment, '', string)
 
         # skip trailing comments
         processed_tokens = []
Severity: normal → critical
Well, first thing is that it is a harness bug. Talos dependencies are not respected, and on harness the latest versions of packages is taken (see bug 1180664, talos dependency to mozprofile==0.24 is not landed).

There is a patch that fixed it - in bug 1185539 - but I think it is only on m-c. We should merge that into other branches as well (aurora, beta, ...). After that, dependencies on harness will be respected for talos needs and we will be good even if internal pypi packages provides newer version that we do not want yet.

So the root cause here is probably bug 1180762. but as I said we should just merge the patch to make harness aware of what talos really needs (so this kind of issues won't happen again).


That being said, we will have to investigate after that to find why mozprofile 0.24 does not work. :nthomas, thanks for the investigation!
landed:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=26c44dd74c22

this should fix it, will see in a couple hours.
Looks like it worked.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.