If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Aries][Settings]Press volume up/down key to adjust the media volume, but the ringtone volume will pop up.

RESOLVED DUPLICATE of bug 1183870

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 1183870
2 years ago
2 years ago

People

(Reporter: Shine(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8638461 [details]
Aries_v2.5_logcat_1725.txt

[1.Description]:
[Aries][v2.5][Settings]Hang up a call, go back to Home screen, press volume up/down key to adjust the media volume, but the ringtone volume will pop up.
See attachment: Aries_v2.5_logcat_1725.txt & Aries_v2.5.3gp
Found Time: 17:25


[2.Testing Steps]: 
1. Launch Dialer app.
2. make a call.
3. During the call, press volume up/down key to adjust the ringtone volume.
** The ringtone volume will pop up.
4. Hang up the call and go back to Home screen.
5. press volume up/down key to adjust the media volume.

[3.Expected Result]: 
5. The media volume will pop up and user could adjust the media volume successfully.

[4.Actual Result]: 
5. But the ringtone volume will pop up and user cannot adjust the media volume.

[5.Reproduction build]: 
Aries v2.5 version (Affected):
Build ID               20150723024716
Gaia Revision          f04fdbfa1943dddeab8ecd1299a76ab56e590d00
Gaia Date              2015-07-22 18:44:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2ddec2dedced
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150723.023231
Firmware Date          Thu Jul 23 02:32:39 UTC 2015
Bootloader             s1

Flame v2.2 version (Unaffected)
Build ID               20150723002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d8326043baec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.041700
Firmware Date          Thu Jul 23 04:17:12 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Flame master version (Unaffected)
Build ID               20150723160204
Gaia Revision          ec2199b324304d3678b6a98a08a31bdc13c9e984
Gaia Date              2015-07-23 17:16:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb8bdb8ffaef
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.193607
Firmware Date          Thu Jul 23 19:36:19 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
5766
(Reporter)

Comment 1

2 years ago
Created attachment 8638462 [details]
Aries_v2.5.3gp
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
This appears to be a duplicate of bug 1183870, where an unexpected audio channel is modified when changing volume. The STR seems to vary across different sections of the device.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183870
You need to log in before you can comment on or make changes to this bug.