Can't build gaia-master alone after a make really-clean, it hangs at basic_code_modules.cc:88: INFO: No module at 0xffffffff

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Reporter)

Description

3 years ago
STR
1. make really-clean
2. make install-gaia

Results
As usual, you can many lines like:
> basic_code_modules.cc:88: INFO: No module at 0xffffffff

The problem is that, in the middle of the build, you're stuck at one of these lines.

Repro environments
1. Linux with my day-to-day repro at a0e9f965b62a72df2a926d40b192db2960d9466c
2. Linux with a brand new gaia repo
3. Linux with a gaia repo from one week
4. Mac OS X with my regular repo

The 2.2 branch is not affected. 

Hence, I'm not sure where to file this bug, but it seems that one of the dependencies of gaia is broken.
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]: Can't build anymore.
blocking-b2g: --- → 2.5?
(Reporter)

Updated

3 years ago
Blocks: 1187330
(Reporter)

Comment 2

3 years ago
Retried at the moment, I could with every environment mentionned in comment 0.
Status: NEW → RESOLVED
blocking-b2g: 2.5? → ---
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Note that the lines like:
> basic_code_modules.cc:88: INFO: No module at 0xffffffff

Is the stack-walker logic trying to get a backtrace of one of the threads.  Probably the main thread because the jank/hang-detector thinks there's jank/a hang.  I agree those are annoying and we probably want to alter the prefs to disable the jank/hang detector, but it's orthogonal to the build process hanging.
You need to log in before you can comment on or make changes to this bug.