Closed Bug 1187439 Opened 9 years ago Closed 8 years ago

[e10s] Scroll inertia not working in Multiprocess

Categories

(Core :: Widget: Win32, defect)

42 Branch
Unspecified
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---

People

(Reporter: alex, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150724030210

Steps to reproduce:

Enable multiprocess in nightly, attempt to flick scroll on a touchscreen.


Actual results:

The page scrolls, but there is no inertia like there is without multiprocess enabled.


Expected results:

Expected behaviour should be no different from scrolling with multiprocess disabled.
OS: Unspecified → Windows 8.1
Component: Untriaged → General
Blocks: e10s
Summary: Scroll inertia not working in Multiprocess → [e10s] Scroll inertia not working in Multiprocess
Component: General → Tracking
Product: Firefox → Core
QA Contact: chofmann
This is a legit e10s regression - there is windows widget nsWinGesture code that handles touch scrolling if APZ touch scrolling is not enabled. And with that code the inertia in scrolling is broken when e10s is enabled (regardless of APZ on or off).

The good news is that setting dom.w3c_touch_events.enabled=2 will stop using the nsWinGesture code and switch to APZ touch scrolling, which has inertia and is much smoother. So whether or not we ship this regression depends on whether or not we ship e10s before APZ touch scrolling is baked (see bug 1180706).
Status: UNCONFIRMED → NEW
Component: Tracking → Widget: Win32
Ever confirmed: true
QA Contact: chofmann
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Just an addendum to comment 1 (thanks Jim for reminding me): touch hardware on Windows triggers accessibility which causes e10s to be disabled, so the e10s regression is not really a thing we need to worry about because it doesn't happen in the default configuration.
You need to log in before you can comment on or make changes to this bug.