Check for updates does not return new updates nor inform user of progress

RESOLVED DUPLICATE of bug 1193910

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1193910
3 years ago
2 years ago

People

(Reporter: Nick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

From a flame with 1.8Dv3 nightly base image, and latest nightly (20150724160206) or any other recent nightly:

Using nightly channel
- Under check for updates, select 'Check now'



Actual results:

- No update is downloaded.
- No feedback is given to user to inform what has happened.


Expected results:

I should be told whether OTA updates are currently available for my device. If not, then a message explaining why should be sent back to the settings app.

E.g. 'No OTA updates are currently available due to ..'
or 'You are already using the latest update'
I think this is because of bug 1085230. Until we get that fixed OTA updates won't work and thus have been disabled IIRC.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085230
(Reporter)

Comment 2

3 years ago
Hi,

Although I can see some connection to the other bug, I have now updated to 1.8Dv4 base image, and a recent nightly (20150801030207). I am still not receiving OTA updates, though the partitioning issue seems to have been resolved.

Also, perhaps its out of context for this bug, but one of the reasons I posted here was because I think the lack of feedback to the user (regarding whether or not an update is available) is important.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193910
You need to log in before you can comment on or make changes to this bug.