Last Comment Bug 1187574 - calendar.context.togglevisible.accesskey is used for multiple strings
: calendar.context.togglevisible.accesskey is used for multiple strings
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Calendar Views (show other bugs)
: Lightning 4.0.1.2
: All All
-- normal (vote)
: 4.4
Assigned To: Matthew Mecca [:mmecca]
:
:
Mentors:
https://transvision.mozfr.org/?source...
: 1178118 (view as bug list)
Depends on:
Blocks: 1073982 1178118
  Show dependency treegraph
 
Reported: 2015-07-25 02:38 PDT by Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo)
Modified: 2015-08-07 07:47 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix v1 (4.76 KB, patch)
2015-07-25 08:25 PDT, Matthew Mecca [:mmecca]
philipp: review+
Details | Diff | Splinter Review

Description User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2015-07-25 02:38:10 PDT
The calendar.context.togglevisible.accesskey applies to showCalendar as well as hideCalendar strings, which does not correspond the l10n files comments, where only showCalendar is mentioned.

Both the strings should have separate accesskeys, because if the calendar.context.togglevisible.accesskey letter is not in the localized hideCalendar string, it will be appended in brackets.
Comment 1 User image Matthew Mecca [:mmecca] 2015-07-25 08:25:40 PDT
Created attachment 8638928 [details] [diff] [review]
Fix v1

Uses a separate access key for Show and Hide calendar
Comment 2 User image Philipp Kewisch [:Fallen] 2015-07-25 09:15:29 PDT
Comment on attachment 8638928 [details] [diff] [review]
Fix v1

Review of attachment 8638928 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick patch, r=philipp
Comment 4 User image Michal Stanke (Mozilla.cz) [:MikkCZ] (off until 05/2017, use needinfo) 2015-08-07 07:47:55 PDT
*** Bug 1178118 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.