Search one-off button layout is broken in 150% dpi and specific window sizes

RESOLVED DUPLICATE of bug 1104325

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1104325
3 years ago
3 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8638945 [details]
Screenshot

[Tracking Requested - why for this release]:

On latest beta, I'm seeing the one-off search layout being busted (150% DPI, windows 10). I'm on PTO and so is Florian. Jared or Tim, do you have time to investigate?

I'm 99% sure this is a regression, but from rural Ireland checking it isn't really an option...
Flags: needinfo?(ttaubert)
Flags: needinfo?(jaws)
Yeah, this is also broken for me in 40 beta 7. WFM in 39, so this is a regression.

It's busted at 150%, but OK at 100%, 125%, and 200%
Keywords: regression
(In reply to :Gijs Kruitbosch (away until Aug 3) from comment #0)
> On latest beta, I'm seeing the one-off search layout being busted (150% DPI,
> windows 10). I'm on PTO and so is Florian. Jared or Tim, do you have time to
> investigate?

I'd love to help but I don't have Win 10 unfortunately...
Flags: needinfo?(ttaubert)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
I reproduced this on Fx39 Release as well as Fx42 Nightly on Windows 8.1.

This appears to have been an issue that has existed since the beginning of one-off search, and just wasn't noticed until now. It is heavily dependent on the window size and also requires a non-integer DPI.

Fx 39 on Windows 8.1: http://screencast.com/t/oCrNLyzrmNyO
Fx 42 on Windows 8.1: http://screencast.com/t/xoTK1hXJ

Working on Fx 40 on Windows 10 with 150% DPI: http://screencast.com/t/51RbBPPGa
status-firefox40: affected → ---
tracking-firefox40: ? → ---
Keywords: regression
Summary: [Windows 10] Search one-off button layout is broken on beta → Search one-off button layout is broken in 150% dpi and specific window sizes
Unassigning as this is not Windows 10 specific and not a regression.
Assignee: jaws → nobody
Status: ASSIGNED → NEW
This is one of the known issues from the new search UI that we never fixed, mostly because I don't have access to a machine reproducing the problem.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1104325
You need to log in before you can comment on or make changes to this bug.