Keywords get broken when bookmark URL is updated

RESOLVED DUPLICATE of bug 1150678

Status

()

defect
RESOLVED DUPLICATE of bug 1150678
4 years ago
4 years ago

People

(Reporter: jan-bugreport, Unassigned)

Tracking

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

1. Open bookmark manager
2. Edit some (very, very old) quicksearch bookmarks (replace http by https)


Actual results:

1. Launching a search via the keyword opens the old (http) URL.
2. After a restart, keywords don't work.
3. Cannot configure keywords for the affected bookmarks. I can put one in, but it doesn't get saved, i.e. it is gone when I switch to a different bookmark and back.
4. [SELECT * FROM moz_keywords LEFT JOIN moz_places ON place_id = moz_places.id] shows NULLs for the moz_places.* fields, i.e. there is no place in moz_places with the ID set to bookmarks.

I thus suspect that the ID of the places changed for some reason when I edited them, but the moz_keywords table didn't get updated.

If it helps, I might be able to pull a copy of the old DB from a backup if requested within the next 1-2 weeks, but this would require lots of effort.


Expected results:

1. Launching a search via the keyword opens the updated URL immediately.
2. Still works after a restart.
3. Can configure keywords.
4. The bookmarks show correctly when querying the DB this way.
Component: Untriaged → Places
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150678
The 3rd issue (inability to assign new keywords) now disappeared (likely after one or more restarts).
You need to log in before you can comment on or make changes to this bug.