title is shown in content if certain css rules are used

RESOLVED DUPLICATE of bug 1128460

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1128460
3 years ago
3 years ago

People

(Reporter: Fedge, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150726004010

Steps to reproduce:

Made a minimal document to display an image ad in an iframe.

CSS consisted of

*,html,body{margin:0;padding:0;display:block;overflow:hidden;}

I'll leave a test case up here: http://milfaletta.com/assets/milfaletta/testcase.html


Actual results:

Title of document is displayed inside the content of the document. This is particularly bad when documents are made to be used inside a specific size of iframe.


Expected results:

Contents of title tag should never be displayed as content.

Comment 1

3 years ago
Just dont use the {display:block} for the universal selector *
------------------------------------------------------------------
Anyway, the result is same with all other browsers, I don't think its a FF bug at all.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → CSS Parsing and Computation
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1128460
You need to log in before you can comment on or make changes to this bug.