If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

News message read should be centered in list pane

RESOLVED FIXED

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Jørn Støylen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.7+) Gecko/20020104
BuildID:    2002010408

When the N/P/F/B commands are used to read messages, the message read should be
vertically centered in the message list pane. It's a useability issue. The way
it works now -- that the message is at the bottom of the pane -- is annoying,
because you can't see the immediately following messages, so you lose overview.
If the message was centered, you'd see it in as much context as possible, and
you'd be able to know if you're about to jump to another thread, for example.

Reproducible: Always
Steps to Reproduce:
1. Open Mail/News window.
2. Read any subscribed-to newsgroup with unread messages outside the list pane.
3. Use N key to read next unread message until the cursor jumps to a post not
visible in the pane.

Actual Results:  The message is displayed at the bottom of the list pane.

Expected Results:  The message should be centered in the list pane.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → laurel

Comment 1

14 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
(Reporter)

Updated

14 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: laurel → message-display

Comment 2

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 3

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED
(Reporter)

Comment 4

8 years ago
Well, I just checked this now, in Thunderbird 2.0.0.24, and it still behaves like that.

This is marked as an enhancement, of course. It's a usability issue, in that if you're going through messages, you'd probably like to have some idea of what's coming next when you hit the N key to jump to the next unread message, and likewise with the other keys.
Status: RESOLVED → UNCONFIRMED
Component: MailNews: Message Display → Folder and Message Lists
Product: SeaMonkey → Thunderbird
Resolution: EXPIRED → ---
Version: Trunk → 2.0
QA Contact: message-display → folders-message-lists
There used to be an extension called threadpane sanitizer that did this, but unfortunately it is now disabled: https://addons.mozilla.org/en-US/thunderbird/addon/threadpane-sanitizer/

If anyone is still interested, the source can be found here: https://bitbucket.org/martinp26/threadpanesanitizer.

I couldn't find any license info in it, but maybe you can find Martin Pollack and ask to take over his project. I might do that myself sometime...
This is now possible by setting mail.threadpane.padding.bottom_percent and mail.threadpane.padding.top_percent to 50. For more info see bug 964824.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.