Empty panel states aren't tablet-optimized

RESOLVED DUPLICATE of bug 1189165

Status

()

Firefox for iOS
Theme & Visual Design
RESOLVED DUPLICATE of bug 1189165
3 years ago
3 years ago

People

(Reporter: bnicholson, Unassigned)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios+)

Details

(Reporter)

Description

3 years ago
The empty history/synced tabs/reading panels look good on phones, but looks awkward on the iPad where they're crammed into the top middle of the view. Maybe we can use larger images/fonts or space things out more? Vertically centering the content might also look better.

Screenshot: https://www.dropbox.com/s/ny32vtu9fnm1ri1/Screenshot%202015-07-27%2010.39.35.png?dl=0
Blocks: 1183213
I think it's better to vertically center the content. It's worth noting that Apple uses vertically centered empty states in many apps (Mail, App Store, Photos, Safari).
I can also work on this.
Flags: needinfo?(bnicholson)
(Reporter)

Comment 2

3 years ago
Question for UX.
Flags: needinfo?(bnicholson) → needinfo?(randersen)
Robin to decide if this is something we should track.
I don't mind if the content is vertically centered, if we can do a few things:
1) Compensate for the bottom nav bar on iPhone portrait—the reason I moved it up in the first place was because even though it was vertically centered it hung too low due to the nav bar
2) Open up the padding a bit more, which would result in having to stack the button on Remote Tabs (like the error template)
3) Add a header to the History panel to visually match the other empty panels
4) Increase the font-size for iPad

Think we could handle all of that in this bug? If not, happy to file separately.
Flags: needinfo?(randersen)
This new bug encompasses what was addressed in this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1189165
tracking-fxios: ? → +
You need to log in before you can comment on or make changes to this bug.