Turn off auto-retries on the permafailing Gip Taskcluster jobs

RESOLVED DUPLICATE of bug 1190385

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 1190385
2 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: garndt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Gip tests running on Taskcluster are currently hidden by default and permafailing. Thanks to our auto-retry logic, that means we're currently running 102 pointless jobs per push to any trunk branch (17 opt, 17 debug, retried 3x). That seems incredibly wasteful. If we can't turn the jobs off outright, we should at least turn off the auto-retries.
(Reporter)

Comment 1

2 years ago
Looks like it comes out to about 25 hours of wasted AWS compute time per push.
(Assignee)

Comment 2

2 years ago
As partially discussed on IRC, there are a couple of things that can be done here:

1. Turn off reruns for Gip
2. Disable Gip entirely
3. Disable Gip on everything but try (so people can still test out patches to green them up)

Turning off automatic reruns is a gain instantly, cutting runs by 2/3.
Assignee: nobody → garndt
(Assignee)

Comment 3

2 years ago
Necessary config changes:

https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/tests/b2g_gaia_ui_test_unit.yml#4
https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/tests/b2g_gaia_ui_test_functional.yml#4
https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/tests/b2g_gaia_ui_test_accessibility.yml#4
(Reporter)

Comment 4

2 years ago
Will be doing this as part of bug 1190385.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190385
You need to log in before you can comment on or make changes to this bug.