White blocks when hovering over tiles on mozilla.org

RESOLVED DUPLICATE of bug 1189837

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1189837
2 years ago
2 years ago

People

(Reporter: jchen, Unassigned)

Tracking

({regression})

Trunk
All
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox41 unaffected, firefox42 affected)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

2 years ago
When I hover over one of the animated tiles on mozilla.org, white blocks appear on the tile.

AFAICT this only happens on Windows (I'm on Windows 7), and this also occurs on other sites (e.g. news.163.com with the scrolling jumbotron and on reddit.com)
Summary: Black blocks → White blocks when hovering over tiles on mozilla.org
(Reporter)

Comment 2

2 years ago
Created attachment 8639444 [details]
Screenshot
Fallout from bug 1157745 I believe. Kats do you know of something on file for this already?
Flags: needinfo?(bugmail.mozilla)
(In reply to Kevin Brosnan [:kbrosnan] from comment #3)
> Fallout from bug 1157745 I believe.

Any particular reason you think this?

> Kats do you know of something on file
> for this already?

Nope, haven't seen this before.
Flags: needinfo?(bugmail.mozilla)
I'm unable to reproduce this on my laptop with Windows 10 nor my desktop PC with Windows 7 on the latest Nightly. Jim, can you please confirm this reproduces with the latest Nightly and then provide your about:support Graphics information?
Flags: needinfo?(nchen)
I can reproduce this on clicking the Android banner.

Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150727030216
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 1/1 (default: true)
Safe Mode: false

Graphics
--------

Adapter Description: Intel(R) HD Graphics Family
Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM: Unknown
Asynchronous Pan/Zoom: wheel input enabled
Device ID: 0x0a16
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17795)
Driver Date: 4-29-2015
Driver Version: 10.18.14.4206
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 221817aa
Supports Hardware H264 Decoding: true
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0a1
gfx.driver-init.deviceID: 0x0a16
gfx.driver-init.driverVersion: 10.18.14.4206
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
(Reporter)

Comment 7

2 years ago
This is mine using a new profile in today's Nightly,

Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150727030216
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 1/1 (default: true)
Safe Mode: false

Graphics
--------

Adapter Description: NVIDIA Quadro 1000M
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Asynchronous Pan/Zoom: wheel input enabled
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 100
Device ID: 0x0dfa
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17292)
Driver Date: 10-28-2013
Driver Version: 9.18.13.1269
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 21cf17aa
Supports Hardware H264 Decoding: true
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA Quadro 1000M Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.startup.homepage_override.buildID: 20150727030216
browser.startup.homepage_override.mstone: 42.0a1
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 42.0a1
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0a1
gfx.driver-init.deviceID: 0x0dfa
gfx.driver-init.driverVersion: 9.18.13.1269
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-eme-adobe.enabled: false
media.gmp-gmpopenh264.enabled: false
media.gmp-manager.buildID: 20150727030216
media.gmp-manager.lastCheck: 1438027192
media.hardware-video-decoding.failed: false
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
plugin.state.npatgpc: 1
privacy.sanitize.migrateFx3Prefs: true
security.sandbox.content.tempDirSuffix: {606ba8db-a901-4280-b0c1-0f215ba0f4fe}
Flags: needinfo?(nchen)
Can either of you confirm that it stops happening if you set layers.async-pan-zoom.enabled to false (and restart the browser)?
Additionally, can you check a couple of builds for me?

> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1437688488/firefox-42.0a1.en-US.win32.installer.exe
This build is where bug 1157745 was landed.
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1437688249/firefox-42.0a1.en-US.win32.installer.exe
This build is the build immediately before bug 1157745 was landed.

If it reproduces in the first build but not the second build that would seem to confirm bug 1157745 as the cause, potentially.
 1:52.49 LOG: MainThread Bisector INFO Last good revision: 738d8ee106fe
 1:52.49 LOG: MainThread Bisector INFO First bad revision: af67b5f73381
 1:52.49 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=738d8ee106fe&tochange=af67b5f73381
Thanks for the regression window! I'm marking this as blocking 1178298 so that we definitely fix it before we let APZ ride the trains.
Blocks: 1178298
[Tracking Requested - why for this release]: nominating to track since this is a regression and should prevent APZ riding the trains (as per comment 11).
status-firefox41: --- → unaffected
tracking-firefox42: --- → ?
Keywords: regression
APZ is nightly only for right now. all-aboard-apz is the metabug for getting rid of the nightly ifdef.
What Kevin said
tracking-firefox42: ? → ---
(In reply to Kevin Brosnan [:kbrosnan] from comment #6)
> I can reproduce this on clicking the Android banner.
> 

I was able to repro also by clicking on the Android banner. On my win8 tablet the mouseover does nothing - there's no mousemove listener attached, whereas there is on OS X, so I assume the page is doing some responsive stuff. Anyway, I can repro the issue and it looks like my patch on bug 1189837 fixes it. I'll dupe this over once that reaches m-c.
Depends on: 1189837
Please verify that this is fixed on the next nightly. Thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
No longer depends on: 1189837
Resolution: --- → DUPLICATE
Duplicate of bug: 1189837
You need to log in before you can comment on or make changes to this bug.