Closed Bug 1188080 Opened 6 years ago Closed 4 years ago

test_rocketbar_offline_behavior.py: "NoSuchWindowException: None"

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: onelson, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [319MB-Flame-Support])

Attachments

(1 file)

Description:
test_rocketbar_offline_behavior is failing consistently today with various 
tracebacks. All the screenshots after failing show the homescreen either blank (with no icons) or an expected homescreen (all icons). Bug 1187015 may have been blocking it, or this could have been a fallout from this issue.

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/192/
* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc.bitbar/153/

Repro Steps:
1) Update phone to 20150727030212
2) Tap Rocketbar to begin searching

Actual:
Keyboard opens then drops, leaves test at search without keyboard; test fails

Expected: 
Keyboard opens and begins search

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/rocketbar/test_rocketbar_offline_behavior.py", line 35, in test_rocketbar_offline_behavior
settings.wait_for_airplane_toggle_ready()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/settings/app.py", line 97, in wait_for_airplane_toggle_ready
self._wait_for_toggle_ready(*self._airplane_checkbox_locator)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/settings/app.py", line 346, in _wait_for_toggle_ready
Wait(self.marionette).until(expected.element_enabled(checkbox))
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/wait.py", line 122, in until
rv = condition(self.marionette)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/expected.py", line 269, in __call__
return self.el.is_enabled()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 116, in is_enabled
return self.marionette._send_message('isElementEnabled', 'value', id=self.id)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 715, in _send_message
    self._handle_error(response)
  File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 751, in _handle_error
    raise errors.lookup(status)(message, stacktrace=stacktrace)
NoSuchWindowException: NoSuchWindowException: None


Environmental Variables:
Device firmware (base) 	L1TC000118D0
Device firmware (date) 	27 Jul 2015 10:39:20
Device firmware (incremental) 	eng.cltbld.20150727.063909
Device firmware (release) 	4.4.2
Device identifier 	flame
Device memory 	219772 kB
Device serial 	1d9a561d
Device uptime 	0 days 0 hours 2 minutes 14 seconds
Gaia date 	24 Jul 2015 11:53:36
Gaia revision 	ade1ef5249cf
Gecko build 	20150727030212
Gecko revision 	d3228c82badd
Gecko version 	42.0a1

Reproducible manually: No

Repro frequency: 5/5
That is not what I see. 
And as can be seen from where the failure is happening, it happens after the settings dialog has been opened.
The problem is that the settings dialog closes by itself automatically after a while. This is something I can also reproduce manually with my 319MB Flame.

Can you reproduce this, Oliver?
Flags: needinfo?(onelson)
The test passes when using 512MB on the Flame.
QA Whiteboard: [memory-failure]
So this looks like a regression. 
Unfortunately, the bitbar results are not useful to find out when this regressed, because of outages and an unrelated failure in that test. But this should be possible to find out manually, because the settings dialog also shows this problem manually.
(In reply to Autolander from comment #4)
> Created attachment 8640725 [details] [review]
> [gaia] mwargers:1188080_disable > mozilla-b2g:master

I disabled this test for now: https://github.com/mozilla-b2g/gaia/commit/eeeea1de6d3946898b01b51de6ba6a40b4dd8d3e
Related to bug 1188603, perhaps?
Whiteboard: [319MB-Flame-Support]
Confirming that I'm also observing this about 50% of the time locally. Probably a little higher fail rate then we'd want, even for unstable. I think disabling this case was a good call.
Flags: needinfo?(onelson)
The changes for Bug 1144132 seem to have caused this issue.  This is more common lately, but has occurred rarely for a while now.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150622155243
Gaia: 9d267dd8dc3cf86c1c0536defc76d16ef1512fd3
Gecko: 3093aa941c7b
Version: 41.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150622044743
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 20d8b6076d9b
Version: 41.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 9d267dd8dc3cf86c1c0536defc76d16ef1512fd3
Gecko: 20d8b6076d9b

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 3093aa941c7b

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/9d267dd8dc3cf86c1c0536defc76d16ef1512fd3...eb0d4aefa62b20420d6fa0642515a110daca5d97
QA Whiteboard: [memory-failure] → [QAnalyst-Triage?][memory-failure]
Flags: needinfo?(ktucker)
Alison, can you take a look at this please? This might have been caused by the landing for bug 1144132. The author is of this landing is no longer available.
Blocks: 1144132
QA Whiteboard: [QAnalyst-Triage?][memory-failure] → [QAnalyst-Triage+][memory-failure]
Flags: needinfo?(ktucker) → needinfo?(ashiue)
I think Gabriele will be back after August 17.

Hi Gabriele, can you help to check this issue? Thank you.
Flags: needinfo?(ashiue) → needinfo?(gsvelto)
Yes, I'm leaving the NI as I've got quite a few 2.5+ blockers to fix first but I'll try to check this out ASAP.
Flags: needinfo?(gsvelto)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.