"/quit" causes many "XPConnect is being called on a scope without a 'Components' property!"-assertions

VERIFIED DUPLICATE of bug 89186

Status

Other Applications
ChatZilla
VERIFIED DUPLICATE of bug 89186
16 years ago
13 years ago

People

(Reporter: Roland Mainz, Assigned: Robert Ginda)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
2002-01-07-08-trunk build on Solaris 7 SPARC
ChatZilla causes lots of "XPConnect is being called on a scope without a
'Components' property!"-assertions when using the "/quit" command from the
ChatZilla view.

Full log:
-- snip --
XXX Damage rectangle (1649,10098,15811,1259) does not intersect the widget's
view (0,0,15810,10081)!
WEBSHELL- = 5
WEBSHELL- = 4
WARNING: DropTimeout proceeding without context., file
../../../../../../../../home/mozilla/src/2002-01-07-08-trunk/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 3993
###!!! ASSERTION: 
XPConnect is being called on a scope without a 'Components' property!

This is pretty much always bad. It usually means that native code is
making a callback to an interface implemented in JavaScript, but the
document where the JS object was created has already been cleared and the
global properties of that document's window are *gone*. Generally this
indicates a problem that should be addressed in the design and use of the
callback code.
: 'Error', file
../../../../../../../../../home/mozilla/src/2002-01-07-08-trunk/mozilla/js/src/xpconnect/src/xpcwrappednativescope.cpp,
line 515
###!!! Break: at file
../../../../../../../../../home/mozilla/src/2002-01-07-08-trunk/mozilla/js/src/xpconnect/src/xpcwrappednativescope.cpp,
line 515
###!!! ASSERTION: 
XPConnect is being called on a scope without a 'Components' property!

This is pretty much always bad. It usually means that native code is
making a callback to an interface implemented in JavaScript, but the
document where the JS object was created has already been cleared and the
global properties of that document's window are *gone*. Generally this
indicates a problem that should be addressed in the design and use of the
callback code.
: 'Error', file
../../../../../../../../../home/mozilla/src/2002-01-07-08-trunk/mozilla/js/src/xpconnect/src/xpcwrappednativescope.cpp,
line 515
###!!! Break: at file
../../../../../../../../../home/mozilla/src/2002-01-07-08-trunk/mozilla/js/src/xpconnect/src/xpcwrappednativescope.cpp,
line 515
###!!! ASSERTION: 
XPConnect is being called on a scope without a 'Components' property!
-- snip --

Comment 1

16 years ago
Isn't this a dupe of bug 89186?

Comment 2

16 years ago
Thank you.

*** This bug has been marked as a duplicate of 89186 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Verified dupe
Status: RESOLVED → VERIFIED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.