3D stutters in Firefox but not in Chrome

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: mbest, Unassigned)

Tracking

(Blocks 1 bug)

38 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [games] gfx-noted, )

Reporter

Description

4 years ago
steps to reproduce:
1. click and hold the 3D island at that top of the page and drag left or right and release
2. this should cause the island to spin
3. not the island stutters as it comes to a stop in Firefox, this same behavior is not seen in Chrome.
Reporter

Updated

4 years ago
Blocks: gecko-games
Whiteboard: [games]

Comment 1

4 years ago
Unable to reproduce on e10s.
I'm unable to reproduce this on my Razerblade laptop in Firefox Nightly 42.0a1 (2015-07-27). Martin, can you please check if this reproduces for you in the latest Nightly? Provide a copy of about:support as well, thanks.
Reporter

Comment 3

4 years ago
Just tested on nightly with e10s and it behaved just like chrome, still some jank from time to time that looks like it was GC pauses but I see the same behavior in Chrome.
(In reply to Martin Best (:mbest) from comment #3)
> Just tested on nightly with e10s and it behaved just like chrome, still some
> jank from time to time that looks like it was GC pauses but I see the same
> behavior in Chrome.

Thanks Martin. Would you mind checking the latest Release, Beta and Dev Edition as well? It appears you originally reported this against Firefox 38 which isn't the current release. Depending where this bug becomes "fixed" may determine whether we let it ride or try to find the fix range for uplift.
I agree, this looks comparable on Nightly 43.

I'm going to mark this WFM, unless you object, :mbest.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mbest)
Resolution: --- → WORKSFORME
Whiteboard: [games] → [games] gfx-noted
Reporter

Comment 6

4 years ago
I think this problem is specific to Optimums cards where we get routed to the slower path.  It may also show up on systems that are lower end.  I recommend a test on Windows to verify that this is not the case.
Flags: needinfo?(mbest)
You need to log in before you can comment on or make changes to this bug.