Reader font type overflow in Japanese

RESOLVED FIXED

Status

()

Toolkit
Reader Mode
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: magicp, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---

Firefox Tracking Flags

(firefox41 affected, firefox42 affected, firefox43 affected, firefox44 affected, firefox45 affected, firefox46 wontfix, firefox47- fixed, firefox48- fixed, firefox-esr45 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8639661 [details]
Reader-font-overflow-in-Japanese.png

User Agent: Mozilla/5.0 (Windows NT 6.3; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

1) Run Firefox (ja-JP)
2) Navigate "Getting Started" (https://support.mozilla.org/ja/kb/get-started-firefox-overview-main-features)
3) View reader mode
4) Click style-button in reader-toolbar


Actual results:

Japanese font overflow.


Expected results:

Should be fit into the area of style-button.
(Reporter)

Updated

3 years ago
Component: Untriaged → Reading List
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

3 years ago
Blocks: 1148050
Keywords: regression
(Reporter)

Updated

2 years ago
Has STR: --- → yes
status-firefox41: --- → affected
status-firefox42: --- → affected
status-firefox43: --- → affected
status-firefox44: --- → affected
OS: Windows 8.1 → All
Hardware: x86 → All
Version: 39 Branch → unspecified
(Reporter)

Updated

2 years ago
status-firefox45: --- → affected
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard

Updated

2 years ago
Component: Reading List → Reader Mode
Product: Firefox Graveyard → Toolkit
(Reporter)

Updated

2 years ago
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox-esr45: --- → affected
Blake, this seems to be a regression from bug 1148050? Can you perhaps look at this?

Where are the 2 misplaced characters coming from? There are normally-sized (english Aa/+/-) controls there too, so seems like this just should be shown at all.

Is it enough to just run a ja-JP-mac localized build to reproduce?
Flags: needinfo?(bwinton)
Too late for beta 46, but we could still take a patch for 47. 
Not a recent regression but sounds like we missed this from last year and it is bad for users.
status-firefox46: affected → wontfix
tracking-firefox47: --- → ?
tracking-firefox48: --- → ?
Yeah, that sounds like this was fixed by a L10N change.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 5

2 years ago
Updating status 47 and 48 to fixed based on comment 4.
status-firefox47: affected → fixed
status-firefox48: affected → fixed
tracking-firefox47: ? → -
tracking-firefox48: ? → -

Comment 6

2 years ago
Hello magicp, could you please verify this issue is fixed on a latest Nightly build? Thanks!
Flags: needinfo?(magicp.jp)
(Reporter)

Comment 7

2 years ago
Created attachment 8748380 [details]
Bug 1188223 - cannot verify in Japanese.png

I confirmed this bug by STR, but reader-mode-button does not appear in Japanese. Please find attached image.
Flags: needinfo?(magicp.jp)

Comment 8

2 years ago
(In reply to magicp from comment #7)
> Created attachment 8748380 [details]
> Bug 1188223 - cannot verify in Japanese.png
> 
> I confirmed this bug by STR, but reader-mode-button does not appear in
> Japanese. Please find attached image.

That's not good. Could you please file a new bug on this issue?
(Reporter)

Comment 9

2 years ago
Created attachment 8748946 [details]
Bug 1188223 - verified.png

I confirmed that this issue is fixed on Nightly build (20160504043118). But confirmed page is below.

https://developer.mozilla.org/ja/Add-ons/WebExtensions/Your_first_WebExtension
(Reporter)

Comment 10

2 years ago
(In reply to Ritu Kothari (:ritu) from comment #8)

> That's not good. Could you please file a new bug on this issue?

Yes I can. What component is this new bug? reader mode or website?

Comment 11

2 years ago
(In reply to magicp from comment #10)
> (In reply to Ritu Kothari (:ritu) from comment #8)
> 
> > That's not good. Could you please file a new bug on this issue?
> 
> Yes I can. What component is this new bug? reader mode or website?

Please file a readability github issue: https://github.com/mozilla/readability/issues
(Reporter)

Comment 12

2 years ago
(In reply to :Gijs Kruitbosch from comment #11)
> (In reply to magicp from comment #10)

> Please file a readability github issue: https://github.com/mozilla/readability/issues

https://github.com/mozilla/readability/issues/290
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.