rewriting of content LT EXCL F BLAH GT changed to LT EXCL HYPHEN SPACE BLAH GT

RESOLVED FIXED in mozilla1.1alpha

Status

()

--
major
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: nneul, Assigned: harishd)

Tracking

({compat, testcase})

Trunk
mozilla1.1alpha
x86
Linux
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020108
BuildID:    2002010808

A image gallery package someone at our site was looking at uses

<!FILENAME> as a placeholder. Chances are that you can't see that - it's
&lt;!FILENAME&gt;

When viewing HTML containing that (such as in a administration form to update
config) mozilla is changing (even for view-source) the content to be <!-
ILENAME>  (&lt;!- ILENAME&gt;)

I'm not sure if those first three chars are reserved for special handling, but
regardless, mozilla shouldn't be changing the content as displayed in the
view-source window.



Reproducible: Always
Steps to Reproduce:
1.Create an html file containing &lt;!FILENAME&gt; (put actual entities in file)
2.Open that HTML file
3.View source

Actual Results:  You'll see the altered content.

Expected Results:  Should see content exactly as typed in the view source window. 

NS 4.x and IE can view it without content being altered.
(Reporter)

Comment 1

17 years ago
Created attachment 64011 [details]
sample html snippet
This must live somewhere in quirks mode comment code.  As a workaround for the
time being, try using real comments <!-- FILENAME --> rather the current 
corruption of a markup declaration.
(Reporter)

Comment 3

17 years ago
Yeah, that's similar to what we did. Problem is that this is a vendor supplied
product with pretty weak template processing. (Exact string substitution only.)
We were willing to go make all the code changes necessary to change the strings
for how it does it's templating, others likely wouldn't be.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: compat, testcase
(Assignee)

Comment 4

17 years ago
Mass move to 1.1
Target Milestone: --- → mozilla1.1
(Reporter)

Comment 5

17 years ago
Looks like this has been fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.