Firefox default web skin is ugly and not configurable

VERIFIED WONTFIX

Status

()

Firefox
General
--
enhancement
VERIFIED WONTFIX
2 years ago
2 years ago

People

(Reporter: Svetlana A. Tkachenko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8639823 [details]
testcase

STR:
1) Write a small simple HTML document.

Actual result:
1) The appearance is simple and ugly, often missing.

Expected result:
1) A nice default theme for the web, preferably one the user can control.

The text should be sans-serif. The tables should be less ugly by default.

The default web skin should be editable by the end user via a gui, just like his/her OS appearance is customizable. Look at how your OS does this in its control panel.
- https://userbase.kde.org/System_Settings/Application_Appearance

Sample document attached.

Updated

2 years ago
Attachment #8639823 - Attachment mime type: text/plain → text/html
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Theme → Layout: View Rendering
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Two things:

1)  The default stylesheet is actually depended on by web pages and can't be changed unilaterally; it's standardized as part of HTML 5.

2)  The rendering engine already supports user stylesheets.  So this is basically a request for UI to create/edit user stylesheets.  Note that some extensions exist for this purpose already.  But in any case, that's not a rendering engine issue; it's a Firefox UI issue.
Component: Layout: View Rendering → General
Product: Core → Firefox
(In reply to Boris Zbarsky [:bz] from comment #1)
> Two things:
> 
> 1)  The default stylesheet is actually depended on by web pages and can't be
> changed unilaterally; it's standardized as part of HTML 5.

Are all parts of the default stylesheet standardized? Is any of it up to the discretion of the user agent? For example could the default font be changed? The default padding/margins on elements? I was under the impression this differed among various rendering engines.
Flags: needinfo?(bzbarsky)
> Are all parts of the default stylesheet standardized?

Pretty much.  There are a few exceptions.

> For example could the default font be changed?

This is one of the exceptions.  The default font can be changed.  If Firefox wants to ship a different default font (or rather fonts, since the default font is language-dependent), it can.  It's all controlled via preferences.

> The default padding/margins on elements? 

No, this can't be changed.

> I was under the impression this differed among various rendering engines.

There are some historical differences that engines are trying to eliminate now that there's an actual spec.
Flags: needinfo?(bzbarsky)
The default font can already be changed using the preferences UI, and I don't think writing UI to obsolete extensions like Stylish is a good use of our time and energy, so I'm going to just mark this wontfix.

If there are very concrete things where we want to change the default that aren't specced yet and/or depended upon by the web at large, we should fix them in separate well-scoped bugs.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

2 years ago
I would like specifically simple interface for configuring websites appearance for users who do not know css. It is a specific narrow scoped request.
(In reply to Svetlana A. Tkachenko from comment #5)
> I would like specifically simple interface for configuring websites
> appearance for users who do not know css.

The preferences/options already have an interface to change the default fonts and colors.

I don't think we want to provide more control than that in the default UI, because it is likely to break websites (in fact, even there both the color and font changes are known to break website usability in some cases).

Especially those same non-technical users that you want this interface for would be frustrated with the outcome of such UI precisely because they would not understand why it didn't "just work". In fact, even for technical users figuring out dependencies on e.g. font metrics is sometimes time-consuming and non-obvious, cf. https://bugzilla.mozilla.org/show_bug.cgi?id=1104439#c6 . We do not have the resources to implement and maintain a much more complex system to detect such breakage and fix it using some unspecified algorithm ("magic"). This is what wontfix means: we will not be implementing this (in the foreseeable future).

>  It is a specific narrow scoped request.

No, it really isn't. What you want would take months if not years of work. See above.

I left the door open for new bugreports that want to change specific unspecced aspects of our default styling (without making it customizable). That is what I meant by "separate well-scoped bugs".
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.