If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Close the control center when the user clicks the tracking protection enable/disable button

VERIFIED FIXED in Firefox 42

Status

()

Firefox
General
P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: MattN, Assigned: ttaubert)

Tracking

({regression})

unspecified
Firefox 42
regression
Points:
1
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify +

Firefox Tracking Flags

(firefox42 verified)

Details

(Whiteboard: [fxprivacy] [campaign])

Attachments

(1 attachment)

To align with the previous TP doorhanger UI and with other UI which changes content, we should close the panel since it doesn't seem like there's much else the user would want to do at the same time in the panel.
Flags: qe-verify+
Flags: firefox-backlog?
Whiteboard: [fxprivacy]
(Assignee)

Updated

2 years ago
Points: --- → 1
(Assignee)

Comment 1

2 years ago
I'll just pick this up because it's such an easy fix.
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Iteration: --- → 42.3 - Aug 10
Flags: firefox-backlog? → firefox-backlog+
(Assignee)

Comment 2

2 years ago
Created attachment 8639923 [details] [diff] [review]
0001-Bug-1188438-Close-the-control-center-when-the-user-c.patch
Attachment #8639923 - Flags: review?(bgrinstead)

Updated

2 years ago
QA Contact: mwobensmith
Whiteboard: [fxprivacy] → [fxprivacy] [campaign]
Comment on attachment 8639923 [details] [diff] [review]
0001-Bug-1188438-Close-the-control-center-when-the-user-c.patch

Review of attachment 8639923 [details] [diff] [review]:
-----------------------------------------------------------------

A simple popup.state check in an existing test file would be good…
Attachment #8639923 - Flags: review?(bgrinstead) → review+

Updated

2 years ago
Priority: -- → P1
(Assignee)

Comment 4

2 years ago
(In reply to Matthew N. [:MattN] from comment #3)
> A simple popup.state check in an existing test file would be good…

Good idea, added to browser/base/content/test/general/browser_trackingUI_5.js.

Comment 5

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/130ef92fa5a7
https://hg.mozilla.org/mozilla-central/rev/130ef92fa5a7
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Verified as fixed using the following environment:

FF 42
Build Id: 20150802030218
OS: Win 7 x64, Mac Os X 10.10, Ubuntu 12.04 x86
Status: RESOLVED → VERIFIED
status-firefox42: fixed → verified
You need to log in before you can comment on or make changes to this bug.