Fix IMMHandler.cpp compilation on mingw.

RESOLVED FIXED in Firefox 42

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jacek, Assigned: masayuki)

Tracking

({inputmethod, regression})

Trunk
mozilla42
x86
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Posted patch fix (obsolete) — Splinter Review
Errors look like this:

IMMHandler.cpp:1240:38: error: invalid initialization of non-const reference of type ‘mozilla::widget::IMMHandler::Selection&’ from an rvalue of type ‘mozilla::widget::IMMHandler::Selection’
Attachment #8639913 - Flags: review?(VYV03354)
Nakano-san, is it correct to copy-construct here?
Flags: needinfo?(masayuki)
Blocks: 1184449
So, not intentional. I'll create a patch for this.
Flags: needinfo?(masayuki)
Comment on attachment 8642322 [details] [diff] [review]
IMMHandler::GetSelection() should use static Selection instance when IME doesn't have focus and return its or mSelection's reference

Review of attachment 8642322 [details] [diff] [review]:
-----------------------------------------------------------------

jacek, is this work with mingw?

::: widget/windows/IMMHandler.h
@@ +438,5 @@
>      bool EnsureValidSelection(nsWindow* aWindow);
> +  private:
> +    Selection(const Selection& aOther)
> +    {
> +      MOZ_CRASH("Don't copy this class");

Selection(const Selection& aOther) = delete;
Please also add
  void operator =(const Selection& aOther) = delete;
Attachment #8642322 - Flags: review?(VYV03354)
Attachment #8642322 - Flags: review+
Attachment #8642322 - Flags: feedback?(jacek)
Comment on attachment 8639913 [details] [diff] [review]
fix

Superceded by Masayuki's patch.
Attachment #8639913 - Attachment is obsolete: true
Attachment #8639913 - Flags: review?(VYV03354)
Comment on attachment 8642322 [details] [diff] [review]
IMMHandler::GetSelection() should use static Selection instance when IME doesn't have focus and return its or mSelection's reference

Works for me, thanks.
Attachment #8642322 - Flags: feedback?(jacek) → feedback+
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/3f700e2cebbcc625c2f2aa6d6d857609e8afd8be
changeset:  3f700e2cebbcc625c2f2aa6d6d857609e8afd8be
user:       Masayuki Nakano <masayuki@d-toybox.com>
date:       Tue Aug 04 17:05:25 2015 +0900
description:
Bug 1188442 IMMHandler::GetSelection() should use static Selection instance when IME doesn't have focus and return its or mSelection's reference r=emk
Assignee: jacek → masayuki
Status: NEW → ASSIGNED
OS: Unspecified → Windows
Hardware: Unspecified → x86
https://hg.mozilla.org/mozilla-central/rev/3f700e2cebbc
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.