Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: \, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

fxos3.0 aries

I had two notifications of 2 SMS' from 2 different people.  When I clicked open, the thread of the one I clicked on had both messages from two different threads mixed together! After navigating back to the thread list, and forward to the single thread, they were no longer mixed.  Very surprising!
Nick, do you happen to have logs ?

Also, do you remember if the SMS application was loaded in background, in one of the threads ?
Not from immediately after it happen; I'll try to be more judicious in capturing them.  The messaging app very likely was open in the background; I'm an avid text-er!
I won't be able to look at this before thursday. Wondering if QA could help finding a STR with the informations we have already.
Keywords: qawanted

Comment 4

3 years ago
Took a look at this. I have tried the following scenarios:
1: Sending messages from two different devices with the same name.
2: Sending the same message with the same name from two different devices.
3: Sending a message with the same contact photo.
4: Sending a message while Aries device is off.
5: Sending a message with  messages running in background. 

Results for all of these scenarios are the same. The 2 threads consistently are remaining separate. Leaving for additional QA to attempt.

Environmental Variables:
Device: Aries 2.5 Kk
Build ID: 20150727165113
Gaia: 302a448729ff2b336581cf94b66327ea836294c7
Gecko: d576f2cec511
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
What I'd like especially to test is:
1. be on thread A in Messages.
2. Press home to move to homescreen.
3. receive a message from A and B.
4. Tap on the notification for A.

This is the only scenario I can think of...
Tried the scenario at comment 5 several times, as well as changing steps a bit, and didn't repro the bug.

We will need the reporter's help to narrow down an STR for this. Changing to steps-wanted.

Tested on:
Device: Aries (RC4 > OTA'ed to dogfood-latest)
BuildID: 20150730145424
Gaia: 1d3595836bd55b70478923d771051268a5dabf91
Gecko: 305ba37a62f8
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5 Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(nick)
Flags: needinfo?(ktucker)
Keywords: qawanted → steps-wanted
Flags: needinfo?(ktucker)
I've yet to see this again, will report back when/if I do.
Flags: needinfo?(nick)
Looks like a rare race then.

Nick, is it possible you got the 2 SMS in a very short succession ? Like after rebooting a phone, or going out of airplane mode, or something similar ? Trying to find where the issue could come.

Note that there is a chance the new navigation from bug 1162030 will either make this disappear or more visible.
I tried the scenario from comment 5 three times and once again with an extra phone. I also ad hoced several scenarios. I was unable to repro with the following build:

Environmental Variables: (no repro)
Device: Aries 2.6
BuildID: 20151208121557
Gaia: 6b430ea7274af4c352de16b75e6bb85d7621ca83
Gecko: 2bdd9ec79799eff3ceec0a318f5a0632d918a527
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
Flags: needinfo?(jmercado)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Three testers have tried and failed to reproduce this issue in addition to the reporter not seeing it any more.  Marking this as WFM for now, please reopen it if it begins occurring again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+][non-reproducible]
Flags: needinfo?(jmercado)
Keywords: steps-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.