Web API guide page sees a subpage that doesn't exist

RESOLVED FIXED

Status

developer.mozilla.org
Wiki pages
--
minor
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

({in-triage})

Details

(Reporter)

Description

3 years ago
This page: https://developer.mozilla.org/en-US/docs/Web/Guide/API

Uses a macro to produce a menu of its subpages.

Included in the list of reported subpages is a "File System API Guide". That page does not exist. That is, it was moved to https://developer.mozilla.org/en-US/docs/Web/API/File_System_API ages ago. For some reason, the macro is still seeing it as a subpage but the data it collects about the page isn't quite right so the link it produces doesn't work.

In particular, in the $children output, you see this:

{"locale": "en-US", "url": "/en-US/docs/WebGuide/API/File_System", "subpages": [{"locale": "en-US", "url": "/en-US/docs/WebGuide/API/File_System/Introduction", "subpages": [], "slug": "WebGuide/API/File_System/Introduction", "title": "Introduction to the File System API"}], "slug": "WebGuide/API/File_System", "title": "File System API guide"}

All the other pages have correct links. (to Web/Guide/ instead of WebGuide/

This might be redirect-related, as the file system API page has moved a couple of times. Redirects shouldn't be included in subpage list requests like this; this should be fixed in the implementation of the '$children' operation on a wiki page.
(Reporter)

Comment 1

3 years ago
OK, looks like a page move gone awry at some point in time, where the parent page is at one URL and the children have a different one. Is this something you guys can fix in the database?
(Reporter)

Updated

3 years ago
Blocks: 1187810
:sheppy - can you check to see if there's other pages with the same bug? Could help us diagnose the cause.

needinfo myself to check the database too.
Severity: normal → minor
Flags: needinfo?(lcrouch)
Flags: needinfo?(eshepherd)
Keywords: in-triage
I can't reproduce this now? Did the macro just need a force-refresh or something? The file system page show the correct topic parent doc in the admin interface: https://developer.mozilla.org/admin/wiki/document/73983/
Flags: needinfo?(lcrouch)
(Reporter)

Comment 4

3 years ago
(In reply to Luke Crouch [:groovecoder] from comment #3)
> I can't reproduce this now? Did the macro just need a force-refresh or
> something? The file system page show the correct topic parent doc in the
> admin interface: https://developer.mozilla.org/admin/wiki/document/73983/

What the hell? You're right, it's fine now. I force-refreshed a ton of times... no idea why it's suddenly okay. This is crazy weird.
Flags: needinfo?(eshepherd)
REOPEN as/if/when needed ...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.