Closed Bug 1188602 Opened 6 years ago Closed 6 years ago

Janky scrolling and bad repainting during APZ scrolling

Categories

(Core :: Panning and Zooming, defect)

Unspecified
Windows
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1157708

People

(Reporter: kats, Unassigned)

References

Details

I cant't see any scrolling issues on those sites on Windows 8.1 and latest Nightly except flickering of the flash content itself (bug 1157708).
(In reply to Emanuel H. from comment #1)
> I cant't see any scrolling issues on those sites on Windows 8.1 and latest
> Nightly except flickering of the flash content itself (bug 1157708).

The scrolling issues go away when Flash is disabled, so this is indeed bug 1157708.

I did also notice when scrolling the *.edu.au page in e10s Nightly on Windows that the last paragraph slightly "shifts" when scrolling reaches the bottom of the page. I could reproduce it on a second e10s profile but not in single-process Nightly. Do you guys see it? Turn Flash off to test.
I still see serious choppiness when mouse-scrolling this page with Flash enabled, regardless of e10s vs single process, or one running Firefox or multiple.
Toggling APZC fixes it though.

http://physicalliving.com/how-to-stabilize-your-shoulders-during-the-pullup-exercise/

Tested on latest Nightly on Windows 7.
Status: UNCONFIRMED → NEW
Ever confirmed: true
If I'm understanding comment 3 correctly, there's jank on that page which APZ fixes, so there's no bug there. And based on comment 2 the original issue reported is the same as bug 1157708. So duping.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157708
You need to log in before you can comment on or make changes to this bug.