Closed Bug 1188603 Opened 7 years ago Closed 4 years ago

[Settings][Ringtones] Share activity closes when attempting to add custom ringtone

Categories

(Firefox OS Graveyard :: Gaia::Ringtones, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: onelson, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][319MB-Flame-Support][systemsfe])

Attachments

(1 file)

Description:
When a user tries to add a custom ringtone from the settings app, they will observe the share activty (and settings app) close, and the active app be returned to homescreen. Note that when creating a ringtone from the Music app, activty will perform as expected and a new ringtone may be set.

PreReq:
* music on device
Repro Steps:
1) Update a Flame to 20150728030208
2) Open Settings app
3) Tap 'Sounds'
4) Tap 'Manage Tones'
5) Tap '+' in top right

Actual:
Share Activity closes, user returend to homescreen

Expected:
Share Activity progresses to user's music


Environmental Variables:
------------------------------

Device: Flame 2.5
Build ID: 20150728030208
Gaia: 14e32276025b0310d3e89027320cf4b2a24cedfb
Gecko: 33dc8a83cfc0
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
============================

Issue DOES NOT REPRODUCE on master for Aries, OR 2.2 for flame devices
Results: Share Activity progresses to user's music

Device: Aries 2.5
BuildID: 20150727151800
Gaia: 4e3e21a4ba3f188b45623ee2297f21d0791f8667
Gecko: 21ca97268bae
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.2
BuildID: 20150728032504
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 9b60e57724db
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
------------------------------

Repro frequency: 5/5
See attached: 
video
logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]:
Functional regression of a core feature

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: lixia
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150622170244
Gaia Revision          c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gaia Date              2015-06-22 23:40:43
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/2ab4034b2cc1
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.052400
Firmware Date          Wed Jun 24 05:24:12 EDT 2015
Bootloader             L1TC000118D0
Firmware Version       v18D v4

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150623190325
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/5a3ee6baf143
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150624.052400
Firmware Date          Wed Jun 24 05:24:12 EDT 2015
Bootloader             L1TC000118D0
Firmware Version       v18D v4

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/2ab4034b2cc1

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gaia Revision          c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/5a3ee6baf143

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/c4d3b8fd78bcd7eff1b127060ec6490a891b7a35...eb0d4aefa62b20420d6fa0642515a110daca5d97
QA Whiteboard: [MGSEI-Triage+]
Regression, blocking
blocking-b2g: 2.5? → 2.5+
Blocks: 1189262
This bug occurs with 319MB memory and not with 512MB memory or both?
(In reply to Martijn Wargers [:mwargers] (QA) from comment #4)
> This bug occurs with 319MB memory and not with 512MB memory or both?

Hi Martijin,

    Yes, this bug only occurs with 319MB memory on the Flame kk master (rate: 5/5), and doesn't occur with 512MB/1024MB memory (rate: 0/15). So this is a memory related problem.
Flags: needinfo?(martijn.martijn)
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][memory-failure]
Flags: needinfo?(martijn.martijn)
Whiteboard: [2.5-Daily-Testing] → [2.5-Daily-Testing][319MB-Flame-Support]
Does this happen if you try to pick a song from the Music app in other places, e.g. when attaching something in the email or SMS apps?
Flags: needinfo?(lixia)
Hi Jim,

    When attaching a song from Music app in Email/SMS app, or sharing a song to E-mail/Messages/Ringtones in Music app, this bug will not happen and music can be added/shared successfully on latest Flame kk v2.5 (Rate: 0/10). Hope this information helps, thanks.


Device: Flame KK 2.5
Build ID               20150811150203
Gaia Revision          2d7f369fd923b6df3b00d76844c413c1202c04ba
Gaia Date              2015-08-11 09:58:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/38c1ea9ccae31700630f1fe0d651e94c0c5b9e1d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150811.182056
Firmware Date          Tue Aug 11 18:21:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Hm, well then it's likely not a regression in the music app. The issue is probably that memory usage increased *just* enough for us to hit OOM on 319MB devices. Since the flow in comment 0 has three apps open (settings, ringtones, and music), it's probably one of the first places to get hurt by an increase in memory usage. I'm not sure there's much I can do on my end; maybe this is something for Gecko folks to look at?

(I still think that 319MB is just plain not enough memory to use Firefox OS on a Flame. We're getting really close to the point where we have to decide between adding new features to Firefox OS *or* ensuring that the 319MB config works.)
Flags: needinfo?(squibblyflabbetydoo)
Gregor, Based on comment 11, not sure if we can do anything on the music/ringtones app side. Do you know who would be the best person to investigate this one. 

Thanks
Hema
Flags: needinfo?(anygregor)
Can we get an 'adb shell b2g-info' right before step 5 and after step 5 from the last good and first broken revision please?

> 4) Tap 'Manage Tones'
> 5) Tap '+' in top right
>
Flags: needinfo?(anygregor)
Keywords: qawanted
Providing b2g-info data on last working and first broken build for qawanted request.

LAST WORKING
20150622170244

BEFORE STEP 5:
                         |     megabytes     |
          NAME  PID PPID CPU(s) NICE  USS  PSS  RSS SWAP VSIZE OOM_ADJ USER    
           b2g  207    1  109.1    0 33.4 36.3 46.6 29.8 297.1       0 root    
        (Nuwa)  421  207    1.6    0  0.0  0.6  3.9  9.1  96.3     -16 root    
Find My Device 2372  421    2.8    0  2.0  4.4 13.8 11.3 112.0      11 u0_a2372
    Homescreen 2638  207   10.3    0  8.7 11.1 20.6 13.7 148.9      10 u0_a2638
      Settings 2648  421    7.7    0 18.8 22.3 33.6  5.6 145.3       2 u0_a2648
     Ringtones 3191  421    2.4    0 14.8 18.0 28.9  3.4 134.3       2 u0_a3191

System memory info:

            Total 214.6 MB
        SwapTotal 192.0 MB
     Used - cache 176.7 MB
  B2G procs (PSS)  92.7 MB
    Non-B2G procs  84.0 MB
     Free + cache  38.0 MB
             Free   2.9 MB
            Cache  35.1 MB
         SwapFree 103.3 MB

Low-memory killer parameters:

  notify_trigger 14336 KB

  oom_adj min_free
        0  4096 KB
       58  5120 KB
      117  6144 KB
      352  8192 KB
      588 20480 KB


AFTER STEP 5:
                          |     megabytes     |
           NAME  PID PPID CPU(s) NICE  USS  PSS  RSS SWAP VSIZE OOM_ADJ USER    
            b2g  207    1  113.3    0 36.4 39.1 48.5 25.6 302.5       0 root    
         (Nuwa)  421  207    1.7    0  0.3  0.9  4.1  8.8  96.3     -16 root    
       Settings 2648  421    7.9    0  4.8  7.4 17.3 19.3 144.6       2 u0_a2648
      Ringtones 3191  421    2.8    0  6.3  9.1 19.4 10.5 131.8       2 u0_a3191
          Music 3240  421    3.1    0 20.0 23.2 33.9  5.1 142.7       2 u0_a3240
(Preallocated a 3302  421    0.9    0 10.0 12.2 20.7  3.8 111.6       1 u0_a3302

System memory info:

            Total 214.6 MB
        SwapTotal 192.0 MB
     Used - cache 175.9 MB
  B2G procs (PSS)  91.9 MB
    Non-B2G procs  84.0 MB
     Free + cache  38.8 MB
             Free   2.1 MB
            Cache  36.6 MB
         SwapFree 112.1 MB

Low-memory killer parameters:

  notify_trigger 14336 KB

  oom_adj min_free
        0  4096 KB
       58  5120 KB
      117  6144 KB
      352  8192 KB
      588 20480 KB


FIRST BROKEN
20150623190325

BEFORE STEP 5:
                         |     megabytes     |
          NAME  PID PPID CPU(s) NICE  USS  PSS  RSS SWAP VSIZE OOM_ADJ USER    
           b2g  211    1  138.5    0 52.7 56.1 65.5 13.0 279.8       0 root    
        (Nuwa)  476  211    2.5    0  0.0  0.9  4.6  9.0  96.3     -16 root    
Find My Device 3769  476    2.1    0  2.9  5.5 14.1 10.5 113.9      11 u0_a3769
      Settings 4007  476    7.7    0 14.7 18.3 28.3  6.1 137.0      10 u0_a4007
     Ringtones 4280  476    2.4    0 13.6 17.2 27.1  5.0 134.3       2 u0_a4280

System memory info:

            Total 214.6 MB
        SwapTotal 192.0 MB
     Used - cache 166.8 MB
  B2G procs (PSS)  97.9 MB
    Non-B2G procs  68.8 MB
     Free + cache  47.9 MB
             Free   3.6 MB
            Cache  44.3 MB
         SwapFree 132.9 MB

Low-memory killer parameters:

  notify_trigger 14336 KB

  oom_adj min_free
        0  4096 KB
       58  5120 KB
      117  6144 KB
      352  8192 KB
      588 20480 KB

AFTER STEP 5:
                         |     megabytes     |
          NAME  PID PPID CPU(s) NICE  USS  PSS  RSS SWAP VSIZE OOM_ADJ USER    
           b2g  211    1  140.8    0 39.1 41.9 52.1 22.6 290.4       0 root    
        (Nuwa)  476  211    2.6    0  0.1  0.9  4.7  8.9  96.3     -16 root    
Find My Device 3769  476    2.1    0  1.7  3.8 12.8 11.7 112.9      11 u0_a3769
      Settings 4007  476    7.7    0  8.9 11.7 22.4 11.7 137.0      10 u0_a4007
     Ringtones 4280  476    2.9    0 10.9 14.4 26.0  4.3 128.4       6 u0_a4280
         Music 4339  476    2.8    0 25.0 28.6 40.2  2.7 142.9       2 u0_a4339

System memory info:

            Total 214.6 MB
        SwapTotal 192.0 MB
     Used - cache 172.9 MB
  B2G procs (PSS) 101.2 MB
    Non-B2G procs  71.7 MB
     Free + cache  41.8 MB
             Free   4.1 MB
            Cache  37.7 MB
         SwapFree 122.2 MB

Low-memory killer parameters:

  notify_trigger 14336 KB

  oom_adj min_free
        0  4096 KB
       58  5120 KB
      117  6144 KB
      352  8192 KB
      588 20480 KB
QA Whiteboard: [MGSEI-Triage+][memory-failure] → [QAnalyst-Triage?][MGSEI-Triage+][memory-failure]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+][memory-failure] → [QAnalyst-Triage+][MGSEI-Triage+][memory-failure]
Flags: needinfo?(jmercado)
b2g-info is now provided. Need your help with this one.
Flags: needinfo?(anygregor)
Priority: -- → P2
Summary: [Settings][Ringtones] Share activitiy closes when attempting to add custom ringtone → [Settings][Ringtones] Share activiiy closes when attempting to add custom ringtone
Summary: [Settings][Ringtones] Share activiiy closes when attempting to add custom ringtone → [Settings][Ringtones] Share activity closes when attempting to add custom ringtone
Seems like a legit crash and a dup of bug 1085667
Flags: needinfo?(anygregor)
Perhaps bug 1197183 is occuring here then? But shouldn't we have to see a crash report here then?
Depends on: 1085667
Whiteboard: [2.5-Daily-Testing][319MB-Flame-Support] → [2.5-Daily-Testing][319MB-Flame-Support][systemsfe]
Not blocking release for Flame 319mb.
blocking-b2g: 2.5+ → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.