[Homescreen] Can appear blank with wallpaper, no icons or search bar; opening and closing task manager will cause draw

VERIFIED FIXED

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8640160 [details]
logcat_20150728_1445.txt

Description:
When the user flashes a new flame build, or has an app Out-of-Memory and drop the user back to homescreen, the user may observe the phone's homescreen reveal their wallpaper, but display no icons or the search bar. If the user were to open and close task manager, the homescreen will begin to draw itself slowly back into place, indicating that it may have missed a draw trigger at some point.
For a potentially easier repro, try to add a custom ringtone on flame devices from settings: bug 1188603. Share activity closes and returns user to broken homescreen.

Repro Steps:
1) Update a Flame to 20150728030208
*) Actual Results
-- or --
2) Open the Browser app
3) Open the website 'www.youtube.com'
4) Play any video
5) Force close browser app

Actual:
Homescreen displays no apps or search bar

Expected:
Homescreen displays all apps and search bar

== or steps from bug 1188603 ==
1) Update a Flame to 20150728030208
2) Open Settings app
3) Tap 'Sounds'
4) Tap 'Manage Tones'
5) Tap '+' in top right

Actual:
Homescreen displays no apps or search bar


Environmental Variables:
------------------------------

Device: Flame 2.5
Build ID: 20150728030208
Gaia: 14e32276025b0310d3e89027320cf4b2a24cedfb
Gecko: 33dc8a83cfc0
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
============================

Issue DOES NOT REPRODUCE on master for Aries, OR 2.2 for flame devices
Results: Homescreen displays all apps and search bar

Device: Aries 2.5
BuildID: 20150727151800
Gaia: 4e3e21a4ba3f188b45623ee2297f21d0791f8667
Gecko: 21ca97268bae
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.2
BuildID: 20150728032504
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 9b60e57724db
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------------------------------

Repro frequency: 2/10
See attached: 
video- https://youtu.be/5YnEE1gayyY
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Severe functional regression (homescreen not drawing)

Requesting a window
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: lixia
QA Contact: lixia
Not sure how we can get a window on a 2/10 repro rate bug but I'll see what I can do.
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng

Comment 3

3 years ago
CentralRegression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150723130445
Gaia: ec2199b324304d3678b6a98a08a31bdc13c9e984
Gecko: cb8bdb8ffaef
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150724020739
Gaia: db299103dd17a873cba4ff88e62ec173bf80fe62
Gecko: b0b3dcfa5557
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working gaia / First Broken gecko - This issue does NOT occur.
Gaia: ec2199b324304d3678b6a98a08a31bdc13c9e984
Gecko: b0b3dcfa5557

Last Working gecko / First Broken gaia - This issue DOES occur.
Gecko: cb8bdb8ffaef
Gaia: db299103dd17a873cba4ff88e62ec173bf80fe62

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/ec2199b324304d3678b6a98a08a31bdc13c9e984...db299103dd17a873cba4ff88e62ec173bf80fe62

This issue is caused by Bug 1186587
Blocks: 1186587
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Bug 1186587 is backed out, so this should be resolved. Can we try to verify once you have a build with that backout?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
QA-Wanted to verify this issue on a build with latest gaia.
Keywords: qawanted, verifyme
QA Contact: pcheng
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Confirmed that with bug 1186587 backed out, this issue is no longer occurring. Homescreen is always shown after doing the STRs, as well as after shallow flashing (tried shallow flashing 5 times with no repro)

Device: Flame (full/shallow flashed, 319MB, KK)
BuildID: 20150730030209
Gaia: bf8565e0c3ad216ccb3f109c17f8a2eb2c42f6b8
Gecko: 62469b20ec84
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5 Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: affected → verified
Flags: needinfo?(ktucker)
Keywords: qawanted, verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.