Closed Bug 1188651 Opened 9 years ago Closed 9 years ago

YouTube video freezes for ~4 seconds at the beginning of the video

Categories

(Core :: Audio/Video, defect)

42 Branch
x86_64
Windows
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1180935

People

(Reporter: nissan4321, Unassigned)

References

()

Details

(Keywords: regression, reproducible)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150728030209

Steps to reproduce:

1) Enter the following YouTube video: https://www.youtube.com/watch?v=8uaoBTBofto
2) First second plays fine
3) On the next 4 seconds, the video is freezed (but the audio is OK).
4) Any interaction after that is totally fine

Notes: 
1) Tested on Nightly with e10s enabled.
2) The video quality seems not to be a factor.


Actual results:

The video got freezed for 4 seconds at the beginning of the video.


Expected results:

The video shouldn't have freezed for ~4 seconds at the beginning.
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
When media.mediasource.enabled is true, this bug appears.
Set it to false, and no freeze is seen.
Also, if not able to reproduce, try to reload without cache to reliably reproduce it (Ctrl + R).
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
[Tracking Requested - why for this release]: regression since Nightlu42.0a1

Steps to reproduce:
1. Clear Recent History, everything (cache, cookies etc) if any
2. Open https://www.youtube.com/watch?v=8uaoBTBofto

Actual results:
First few seconds of YouTube video are visually distorted

Expected Results:
No distortion.


Setting media.mediasource.format-reader = false helps


Most recent regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=706318c7d595&tochange=d3228c82badd

Regressed by:
d3228c82badd	Jean-Yves Avenard — Bug 1171379: P1. Enable MediaSourceDemuxer by default. r=kentuckyfriedtakahe a=bustage


Screen capture: attachment 8640525 [details]
Video Stat : attachment 8640527 [details]
Blocks: 1171379
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: regression
OS: Windows 8.1 → Windows
Resolution: DUPLICATE → ---
Component: Untriaged → Audio/Video
Keywords: reproducible
Product: Firefox → Core
Version: Trunk → 42 Branch
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 1180935 ***

Do not duplicate without a evidence.
It's the exact same video, and depending on which resolution displayed is that same as bug 1180935. Seems evidence enough to me
(In reply to Jean-Yves Avenard [:jya] from comment #8)
> I was referring to https://bugzilla.mozilla.org/show_bug.cgi?id=1180935#c4

I see. 
You said bug 1180935 was fixed in bug 1180935 Comment 43.

But, I can still reproduce this problem on Latest Nightly(2015-08-02).
So, this is a definitely different bug.
This one is very puzzling.

I can see the WMF decoder being fed data properly between 0 and 5.8s
but it only outputs the two keyframes found at t=1s and t=5.33s everything in between (128 frames) are lost
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Untracking because already tracked in duplicate bug 1180935.
Blocks: 1197083
No longer blocks: 1197083
You need to log in before you can comment on or make changes to this bug.