[Calendar] Unable to set 'default account' for events

RESOLVED DUPLICATE of bug 920189

Status

RESOLVED DUPLICATE of bug 920189
3 years ago
3 years ago

People

(Reporter: onelson, Unassigned)

Tracking

({feature})

unspecified
ARM
Gonk (Firefox OS)
feature

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing], [Spark], URL)

(Reporter)

Description

3 years ago
Description:
When a user adds an email account to their Calendar app, they will observe an inability to set the default account for new events with events always attempting to set for the first set email account. Seems inconvenient if a user wanted to sync multiple email calendars, and they cannot quickly choose the calendar they want to add events too quickly. If the user stops observing the events from a specific account, they will observe it is still the default account for new events.

Repro Steps:
1) Update a Flame to 20150728030208
2) Open Calendar app
3) Tap the pancake icon (top-left)
4) Tap the 'gear' icon
5) Add a new account from gmail
6) Return to Calendar
7) Add an event
8) Observe default account for event listed
9) Repeat 3-8 and add another gmail account
10) Repeat 9 with a yahoo email

Actual:
After new emails are added, default account for new events always list the first added account.

Expected:
After new emails are added, latest email is the default for adding events
User can set a default account when creating new events


Environmental Variables:
------------------------------

Device: Aries 2.5
BuildID: 20150727151800
Gaia: 4e3e21a4ba3f188b45623ee2297f21d0791f8667
Gecko: 21ca97268bae
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.5
Build ID: 20150728030208
Gaia: 14e32276025b0310d3e89027320cf4b2a24cedfb
Gecko: 33dc8a83cfc0
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.2
BuildID: 20150728032504
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 9b60e57724db
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150724001207
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20150723000207
Gaia: b16ba05481e577bc644ed8966f587a70fe2148e6
Gecko: 2e6f1d4deff9
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
------------------------------

Repro frequency: 5/5
See attached: 
video- https://youtu.be/4XU2wex9NLE
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(twen)

Comment 2

3 years ago
[Blocking Requested - why for this release]:

I think this would improve user experience if fixed, however I am not sure if Calendar UI will be changed under NGA. Nominate it for V2.5 for triage decision.
blocking-b2g: --- → 2.5?
Flags: needinfo?(twen)
Moving to feature request, will not take this one on for 2.5. Gareth has done some work on this previously and may have another bug to dupe to.
blocking-b2g: 2.5? → ---
Flags: needinfo?(gaye)
Keywords: feature
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gaye)
Resolution: --- → DUPLICATE
Duplicate of bug: 920189
You need to log in before you can comment on or make changes to this bug.