Cant cancel out of menu in https://m.youtube.com

VERIFIED DUPLICATE of bug 1196921

Status

Firefox OS
Gaia
VERIFIED DUPLICATE of bug 1196921
3 years ago
3 years ago

People

(Reporter: sfoster, Unassigned)

Tracking

({foxfood})

unspecified
All
Other
foxfood

Firefox Tracking Flags

(b2g-v2.5 verified, b2g-master verified)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
>> Feature Request Summary:
Cant cancel out of menu in https://m.youtube.com

>> Description of feature, or problem to be solved
I find taps on the 'Cancel' button in the options menu (top-right, 3 vertical dots) in the mobile youtube site have no effect.  (m.youtube.com is where the YouTube homescreen icon takes you) This is annoying as they use a lightbox thing so you have to reload the page to dismiss the dialog/menu. 

I've had a quick look in the webIDE and the only thing that jumped out at me was that the container #koya_child_687 > div:nth-child(1) has aria-hidden=true - I'm not sure if that would interfere with the cancel button getting focus and doing its cancelling thing - in a way that is not an issue with other browsers
(Reporter)

Comment 1

3 years ago
Created attachment 8640322 [details]
youtube-com-cancel-menu.png

Screenshot of the menu w. cancel button
Can we get a logcat please?  Not sure if there's anything in the logs that would help indicate what the issue is; at the same time there may be a clue...
Flags: needinfo?(sfoster)
(Reporter)

Comment 3

3 years ago
Created attachment 8645781 [details]
youtube-cancel.log

logcat, I restarted, clicked youtube icon on homescreen, tapped ':' icon to get actions menu. Tapped 'cancel' which did nothing.
Flags: needinfo?(sfoster)
QA Whiteboard: [foxfood-triage]

Updated

3 years ago
Component: Gaia::Feedback → Gaia
Duplicate of this bug: 1227673
It works on FX for Android. Kats, do you think thats a APZ bug?
Flags: needinfo?(bugmail.mozilla)
Sounds like a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1196921 which should be fixed now, can you retest to see if it is still happening?
Flags: needinfo?(bugmail.mozilla) → needinfo?(sfoster)
Keywords: qawanted
(Reporter)

Comment 7

3 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> Sounds like a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1196921
> which should be fixed now, can you retest to see if it is still happening?

Works for me now on master \o/. I'll leave the qawanted but I suggest we dupe to 1196921 if confirmed.
Flags: needinfo?(sfoster)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: qawanted → verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1196921

Comment 9

3 years ago
This bug has been verified as "pass" on the latest build of Aries KK master by the STR in comment 0.

Actual result: The menu is dismissed when tapping the cancel button.
See attachment: Verified_Aries_KK_master.3gp
Reproduce rate: 0/10.

Device: Aries KK master( Pass )
Build ID               20151125150203
Gaia Revision          9eca89f04628c99226e0d18c15d5ae11b71af0cf
Gaia Date              2015-11-25 06:47:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35916735b8afc5b0732e00f9aeb56bf846bba7f4
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151125.185730
Firmware Date          Wed Nov 25 18:57:42 EST 2015
Bootloader             L1TC000118D0

Comment 10

3 years ago
Created attachment 8692298 [details]
Verified_Aries_KK_master.3gp

Updated

3 years ago
QA Whiteboard: [foxfood-triage] → [foxfood-triage][MGSEI-Triage+]
status-b2g-master: --- → verified

Comment 11

3 years ago
This bug has been verified as "pass" on the latest build of Aries KK v2.5 by the STR in comment 0.

Actual result: The menu is dismissed when tapping the cancel button.
Reproduce rate: 0/10.

Device: Aries KK v2.5(Pass)
Build ID               20151125233358
Gaia Revision          93b8bf2de3258c25199d97036c50a87667059148
Gaia Date              2015-11-25 10:29:48
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/a883c12a75da3fa58b64bcb94923b013c71f546a
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151125.224212
Firmware Date          Wed Nov 25 22:42:20 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
status-b2g-v2.5: --- → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.