Last Comment Bug 11888 - IMAP: Quoting in Reply/Forward of msgs containing non-ASCII characters in body is broken
: IMAP: Quoting in Reply/Forward of msgs containing non-ASCII characters in bod...
Status: VERIFIED DUPLICATE of bug 15465
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: x86 Windows NT
: P3 normal (vote)
: M11
Assigned To: Scott MacGregor
: Katsuhiko Momoi
Mentors:
: 13382 (view as bug list)
Depends on:
Blocks: 7228 11091 14356
  Show dependency treegraph
 
Reported: 1999-08-13 18:05 PDT by Katsuhiko Momoi
Modified: 2008-07-31 01:21 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Katsuhiko Momoi 1999-08-13 18:05:13 PDT
** Observed with 8/13/99 Win32 build **

** This bug was split from Bug 11763 which conflated 2 bugs into
   one and was confusing.

When replying or forwarding messages containing
non-ASCII body text on IMAP servers, auto-quoting produces
broken text. Here's a set of steps to reproduce this bug:


1. Select a JPN msg (HTML or plain)containing a Japanese header & body text
   with no attachment
2 [details] [diff] [review]. Now reply or forward (w/ auto auto) either under HTML or plain text mail
   send.
3. You see that the Message window body seems to be in raw JIS rather than
   in Japanese.

Note: header quote is not working -- this is a known bug.
      But the body text quote should show in Japanese.

Note 2: I tried Latin1 body text and this seems to be working
        in quoting both body and Subject header.
Note 3: quoting UTF-8 body does not work correctly.

Here's rhp's comment on this bug from Bug 11763:

------- Additional Comments From rhp@netscape.com  08/13/99 12:20 -------
Ok, here is the deal.

The quoting we do with IMAP is a hack that is guaranteed not to work for
Japanese or any other non us-ascii text...and it didn't ever work. I am waiting
on a stream routine from mscott that won't be in the product until M10.
Comment 1 Katsuhiko Momoi 1999-08-13 18:05:59 PDT
Assigning myself as QA contact.
Comment 2 Scott MacGregor 1999-08-16 11:26:59 PDT
Rich, (I don't profess to understand this bug) why will hooking up to the stream
converter fix this problem? (I do have that bug in on my M10 plate). Is it part
of your hack that will go away when we have that in place?
Comment 3 rhp (gone) 1999-08-16 11:45:59 PDT
Yes, the hack that is in place is digging through the tempMessage.eml file on
disk to try to snarf some body text. This is because the SaveToDisk() method is
only implemented for local folders (not IMAP or NTTP). When the stream is in
place, the hack goes away for good.

- rhp
Comment 4 rhp (gone) 1999-08-16 11:50:59 PDT
Uh, that's NNTP :-)
Comment 5 Phil Peterson 1999-08-19 16:18:59 PDT
Reassign to mscott to hook up streams from IMAP and NNTP to compose backend.
Comment 6 Phil Peterson 1999-08-27 11:00:59 PDT
Triage to M11
Comment 7 nhottanscp 1999-09-08 15:18:59 PDT
*** Bug 13382 has been marked as a duplicate of this bug. ***
Comment 8 Scott MacGregor 1999-09-17 14:16:59 PDT
Kat, can you check out this bug again and see if the problem is still there?
Rich mentioned in this report that he needed some new interfaces from me. I've
done that and with some help from jefft, quoting for reply or forward no longer
uses a temp file. Rich's comments made me thing that things will just work once
I did that. So this bug may already be fixed.
Comment 9 nhottanscp 1999-09-17 15:08:59 PDT
I got a related bug 14189 today. Although I cannot reproduce it but it happens
randomly. So it looks like not completely fixed.
Comment 10 Katsuhiko Momoi 1999-09-17 15:13:59 PDT
I think "randomly" is a charitable word. It happens at least 50%
of the time with me. Sometimes text get quoted all right and sometimes
they are broken/corrupted. This applies to Latin 1, JPN, UTF-8, etc.
text body.
Comment 11 Katsuhiko Momoi 1999-09-17 15:17:59 PDT
Scott, Bug 14189 applies to both IMAP & POP3 mail quoting.
Does your fix here affect POP3, too? I thought this bug was
about IMAP quoting and Rich's and your fix applied only to that.
Comment 12 Scott MacGregor 1999-09-20 13:19:59 PDT
It's entirely possible that this bug is a dup of 14189 (or vice versa). quoting
for reply and forward runs through the same code for both pop and imap now. To
me, I would think this bug should happen to both the imap and pop case.
Comment 13 lchiang 1999-09-20 16:01:59 PDT
(target milestone is M11 or M12 - add to mail beta tracking bug)
Comment 14 Scott MacGregor 1999-09-20 22:58:59 PDT
I18N: I don't know enough about what's going on here I think. To my ignorant
eyes, this bug and Bug #8405 seem to be the same problem. (Please ignore the
imap specific nature of this bug..I think the problem is in both pop and imap).
Can we mark one as a dupicate of the other? Which one do you think has the
better problem statement? Thanks for the help!
Comment 15 nhottanscp 1999-09-21 09:35:59 PDT
For 8405, I attached a screen shot and the data. The first message contains
Japanese both subject and from address but only subject shows and address is all
truncated (shows only dots), not sure wheather converted wrong or truncated
problem.

This bug shows not dots but something like raw UTF-8 string. So looks different
from 8405 but could be the same internally, I am not sure.
I think we better have a screen shot of this too. This is reproducable using the
i18n smoke test. Marina, could you attach a screen shot for this, I cannot
reproduce this bug?
Comment 16 Katsuhiko Momoi 1999-10-22 21:18:59 PDT
Reviewing this bug at this juncture, it seems to me that the bug
as I described 8/13/99 no longer exists.
HTML quoting of Japanese is OK now. It is certainly not
quoting raw JIS (with all MIME-encodign intact).
There is Forward/inline bug which shows raw B-encoded ISO-2022-JP
headers but that is covered by Bug 17034.
That leaves body corruption in Plain Text mail which is covered by
Bug 15465.
In any case the kind of dichotmy I noted between IMAP and POP mail
in quoting does to seem to exist any more, either.

Unless someone objects, I'm inclined to mark this bug as
a duplicate of Bug 15465 or Worksforme since the problem as dsecribed
originally seems to be gone now.
Comment 17 Phil Peterson 1999-11-02 16:26:59 PST
Marking dup per kat's comments.

*** This bug has been marked as a duplicate of 15465 ***
Comment 18 Katsuhiko Momoi 1999-11-09 10:58:59 PST
Verified as a duplicate of multiple bugs.

Note You need to log in before you can comment on or make changes to this bug.