No gUM dialogue on Fennec for several WebRTC sites

RESOLVED DUPLICATE of bug 1189058

Status

()

Core
WebRTC: Audio/Video
P1
normal
Rank:
10
RESOLVED DUPLICATE of bug 1189058
3 years ago
2 years ago

People

(Reporter: RT, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(fennec41+)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Environment: Nexus 5 on Android 5.1.1
Happens on Firefox for Android release, Beta and Nightly
Happens on gUM test page but also Firefox Hello and talky.io

STR:
1 Go to https://mozilla.github.io/webrtc-landing/gum_test.html
2 Select Video
3 The buttons turn to "Stop", "Pause/Play" and "Snapshot" but the browser does not prompt me to share my camera (same applies if I select "Audio")
(Reporter)

Comment 1

3 years ago
Note: Talky.io and Firefox Hello work fine on Chrome for Android on the same phone.
tracking-fennec: --- → ?
FWIW WFM on Samsung S4 on 39, 40 and 42. Any errors in Tools -> Console? (w/add-on [1]) 

[1] https://addons.mozilla.org/EN-uS/android/addon/console
(Reporter)

Comment 3

3 years ago
Here is what I get:
    « window.controllers » est obsolète. Ne l'utilisez pas pour détecter l'agent utilisateur (UA).browser.js17:9:41.495
-> « window.controllers » is obsolete, do not use it to detect the user agent (UA).browser.js17:9:41.495

    L'objet « Components » est obsolète. Il sera bientôt supprimé.utils.js17:9:42.742
-> The object « Components » is obsolete. It will soon be deletedutils.js17:9:42.742 

    StandaloneRoomView.shouldRenderRemoteVideo: unexpected roomState: room-gather17:9:43.274

    « window.controllers » est obsolète. Ne l'utilisez pas pour détecter l'agent utilisateur (UA).browser.js17:10:13.289
    TypeError: this.target.hasAttribute is not a function
> StandaloneRoomView.shouldRenderRemoteVideo: unexpected roomState: room-gather17:9:43.274

Wow, didn't know we localized our web console.

Looks like you did Firefox Hello this time, maybe Mark knows what that means?
Flags: needinfo?(standard8)
Gian-Carlo -- Can you take a look at this for me?  It appears as if it's Android specific (perhaps even device and OS specific).  No one is seeing it on Desktop -- and it doesn't repro on all Android systems.  

If you can isolate what the problem is, that would be a huge help.  If it's trivial, I'd love a fix, and if it's not, even laying out the problem and how to approach a solution would save me/the team a bunch of time.

I know you're trying to land your sandboxing work, but this is a nasty bug if someone hits it.  Thanks.
backlog: --- → webRTC+
Rank: 10
Flags: needinfo?(gpascutto)
Priority: -- → P1
Do we know any Android devices on which it *does* reproduce aside from the Nexus 5?
Flags: needinfo?(gpascutto)
(In reply to Gian-Carlo Pascutto [:gcp] from comment #6)
> Do we know any Android devices on which it *does* reproduce aside from the
> Nexus 5?

I do not.  I'm adding Kevin to the cc.

Kevin -- Can you try to repro this problem on some of the phones you have?  (Nexus 5 is known to fail.)
Flags: needinfo?(kbrosnan)
An adb logcat from a Nexus 5 may be useful too.
RT, this works for me on a nexus 5 running 5.1.1 with todays nightly. Can you retest and post a log?
Flags: needinfo?(rtestard)
(Reporter)

Comment 10

3 years ago
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #9)
> RT, this works for me on a nexus 5 running 5.1.1 with todays nightly. Can
> you retest and post a log?

Here is what I get with Firefox Hello (load page and click "JOIN" - no gUM prompt on Nightly):
http://pastebin.com/nnzvinsf

Yesterday the same thing happened on release, beta and nightly although today release works fine whereas beta and nighly fail to show the gUM prompt.

Let me know if I can provide more details here to help troubleshoot.
I NI Gareth since we may be running optimizely tests on that page (I see mentions to optimizely in the logs) - Gareth are we running variations of that page at the moment that may explain inconsistent behavior?
Flags: needinfo?(rtestard) → needinfo?(garethcull.bugs)
Tests for Firefox Hello have been on pause and have not been running since July 17.
Flags: needinfo?(garethcull.bugs)
(In reply to Jan-Ivar Bruaroey [:jib] from comment #4)
> > StandaloneRoomView.shouldRenderRemoteVideo: unexpected roomState: room-gather17:9:43.274
> 
> Looks like you did Firefox Hello this time, maybe Mark knows what that means?

That's just a spurious log from Hello, its harmless wrt Hello's functionality.
Flags: needinfo?(standard8)
RT can you retest?
Flags: needinfo?(rtestard)
(Reporter)

Comment 14

3 years ago
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #13)
> RT can you retest?

Using Firefox Hello now works for no apparent reason (I have not updated nightly since the last time it failed).
Talky.io although still fails when reaching https://talky.io/under-a-still-surf which should prompt me automatically to share my mic and cam when reaching the URL (Chrome does it), here are the logs:
http://pastebin.com/RER7N02N
Flags: needinfo?(rtestard)
Nothing gUM related in that log, but:

E/GeckoConsole( 5828): [JavaScript Error: "La connexion avec wss://anon.talky.me
/xmpp-websocket a ├®t├® interrompue pendant le chargement de la page." {file: "h
ttps://talky.io/bundle.js" line: 62}]
(Reporter)

Comment 16

3 years ago
Gareth, I just had a conversation with Dan who told me you noticed a drop in people granting access to camera and microphone recently on Hello when using Firefox for Android.
Could you please help us understand when you noticed a difference happened in the "Grand media" events so we can further identify when something may have changed in the code?
Flags: needinfo?(garethcull.bugs)
Just following up on our conversation earlier today on IRC.

I only see significant drop-off in Join a conversation and Grant Media Events for Firefox for Android 40 users. Firefox 39 users have a significantly higher Join and Grant Media Rates. I also trended Grant Media Rates among all Firefox for Android Users, and noticed that we started to see a some decline in this conversion rate around early June.  Not sure if anything happened around that time. Has anyone figured out what could be causing this in Firefox for Android 40?

See data for more details:
https://docs.google.com/a/mozilla.com/spreadsheets/d/1juw6lUzfAPPNgXSCGPxcgtUJ3JdDryhu11JhiwLu0Y4/edit?usp=sharing
Flags: needinfo?(garethcull.bugs)

Updated

3 years ago
See Also: → bug 1193030
This works for me on a Nexus 5 running Android M preview 2. Using Firefox 40, 41 and 42. 

Used the video button several times per release and I got the camera control dialog. Used the stop/pause/play buttons to pause, enter and exit recording. Swiped closed the active recording tab and loaded the page again, the dialog appeared as expected. Switched between apps on the phone and back to Firefox loaded the page, dialog appeared as expected.
Flags: needinfo?(kbrosnan)
(In reply to Gareth Cull [:garethc] from comment #17)
> I also trended Grant Media
> Rates among all Firefox for Android Users, and noticed that we started to
> see a some decline in this conversion rate around early June.  Not sure if
> anything happened around that time. Has anyone figured out what could be
> causing this in Firefox for Android 40?

I'm not clear *on which channel* and around *what date* you saw this problem. You say "Firefox 40" but is this when it was in Nightly/Aurora or ... ?

I'm reading the release schedule and the trains moved in mid May and the end of June, So if you say "early June" and "Firefox 40" this doesn't seem to make much sense because between those dates there would have been no big changes.
Note that it's possible for a UI/JS change in Hello to have triggered a bug in Firefox for Android, so correlating with Hello changes might also help.
(In reply to Gareth Cull [:garethc] from comment #17)
> Has anyone figured out what could be causing this in Firefox for Android 40?

Is this not explained by Bug 1189058?
RT -- Which version(s) of Firefox are you using for your testing?  All active versions (Fx39 to Fx43) or just a subset?

Gian-Carlo -- Since RT is the only one who can repro this (when using talky.io), is there anything he can do (any logs he can enable) to get us more info on this so we can push this investigation  forward?  

Also, we know the folks at talky.io pretty well;  I believe they'd be willing to help us debug this some.  Is there anything they could be doing (UI wise) that would trigger something like this on Android?  Is there anything we'd like them to try?
Flags: needinfo?(rtestard)
Flags: needinfo?(gpascutto)
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #22)

> Gian-Carlo -- Since RT is the only one who can repro this (when using
> talky.io), is there anything he can do (any logs he can enable) to get us
> more info on this so we can push this investigation  forward?  

I would ask for an adb logcat but he already provided one and it shows absolutely nothing, i.e. there isn't a single log message from the Android WebRTC stack in the trace. As far as I can tell isn't never even started to begin with.

> Is this not explained by Bug 1189058?

That bug (combined with irrelevant changes that alter timings) could explain it, yes. The "timing" part could explain the problems in reproducing. But in that case it should be impossible to reproduce on versions where that bug is fixed.
Flags: needinfo?(gpascutto)
RT -- Are you seeing this problem (with talky.io) using all versions of Firefox?  Or just a subset?  If you could retest once more, I'd appreciate it.  Thanks.
(Reporter)

Comment 25

3 years ago
I had the issue on release, beta and nightly when I raised the bug although testing now I can only reproduce with talky on release (currently on 39, holding to update since the issue may go away). I updated Nightly but did not update Beta so it's strange the result changed.
I can also reproduce with Hello on release.

I attach 2 logcats when using with talky or hello using release 39.

I am using a windows machine and I use abd logcat > logcat.txt to create the dump file I attach - if this is not giving you the logs you expect please let me know how I should proceed. I have a mac too but I could not get the terminal to detect my phone when running adb.
Flags: needinfo?(rtestard)
(Reporter)

Comment 26

3 years ago
Created attachment 8646884 [details]
logcat - talky_39.0_nexus5_Android5.1.1.txt

Logcat for Talky
(Reporter)

Comment 27

3 years ago
Created attachment 8646885 [details]
logcat - hello_39.0_nexus5_Android 5.1.1.txt

Logcat for Hello
Those versions do seem consistent with bug 1189058. The first log has no WebRTC info, the second one does show the cameras being enumerated, but nothing after that.
Given that no one can repro this in Fx 40 (the current release as of this week) or later releases and the latest logs seem consistent with bug 1189058 (which was fixed and uplifted to Fx 40, but not Fx 39), I'm closing this as a dup of 1189058. If anyone sees this problem in Fx 40 or later, we can reopen this -- or better yet open a new bug with fresh logs. Thanks.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1189058
This needs to track 40, mirroring the duped bug, but the flags are messed up.
tracking-fennec: ? → 41+
Duplicate of this bug: 1193030
You need to log in before you can comment on or make changes to this bug.