Firefox crashes when skipping through HTML5 video

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: jj, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.1.0
Build ID: 20150703062643

Steps to reproduce:

I started firefox with `firefox --safe-mode`, then opened a Youtube video and tried to forward into the video by clicking various locations on the "video timeline bar". After about 5-10 clicks, firefox crashes.


Actual results:

Here is the output from the terminal where Firefox was started:

jj@legend ~ % firefox --safe-mode

(process:4834): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
console.error: 
  [CustomizableUI]
  Custom widget with id loop-button does not return a valid node
console.error: 
  [CustomizableUI]
  Custom widget with id loop-button does not return a valid node

** (iceweasel:4834): CRITICAL **: gst_video_codec_frame_ref: assertion 'frame != NULL' failed
[1]    4834 segmentation fault (core dumped)  firefox --safe-mode
firefox --safe-mode  18.92s user 1.98s system 46% cpu 45.408 total
139 jj@legend ~ %

Please let me know if there is anything I can do to gather more information about this problem (where are the logs?).


Expected results:

Obviously firefox shouldn't segfault, especially not in safe mode. Note that this problem also occurs in regular mode.

Comment 1

3 years ago
Do you have a stacktrace?
https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

3 years ago
Well, I do, but it's not very helpful:

Core was generated by `iceweasel --safe-mode'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f571a44e79b in ?? ()
(gdb) bt full
#0  0x00007f571a44e79b in ?? ()
No symbol table info available.
#1  0x00007f5716ac5987 in ?? ()
No symbol table info available.
#2  0x00007f56dcafdfc0 in ?? ()
No symbol table info available.
#3  0x00007f56dcafe0f0 in ?? ()
No symbol table info available.
#4  0x00007f56df3b1930 in ?? ()
No symbol table info available.
#5  0x0000000000000400 in ?? ()
No symbol table info available.
#6  0x0000000000000000 in ?? ()
No symbol table info available.

Let me see if I can get a better stacktrace with a build from mozilla.org. Will report back later.

Comment 3

3 years ago
What's the version of Gstreamer you're using to read HTML5 videos?
(Reporter)

Comment 4

3 years ago
First of all, I downloaded firefox-39.0.tar.bz2 from the Mozilla website to see if I can reproduce the problem and get an informative stacktrace. I couldn't. No matter how much I skip over Youtube videos, the official Firefox build never crashes. Since I can't seem to reproduce my own bug anymore, this report should probably be closed.

Second, here is the output of `dpkg -l | grep gstreamer`:

jj@legend ~ % dpkg -l | grep gstreamer
ii  gir1.2-gstreamer-1.0                         1.4.5-2                             amd64        Description: GObject introspection data for the GStreamer library
ii  gstreamer0.10-gconf:amd64                    0.10.31-3+nmu4+b1                   amd64        GStreamer plugin for getting the sink/source information from GConf
ii  gstreamer0.10-nice:amd64                     0.1.7-1                             amd64        ICE library (GStreamer 0.10 plugin)
ii  gstreamer0.10-plugins-bad:amd64              0.10.23-8                           amd64        GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-base:amd64             0.10.36-2                           amd64        GStreamer plugins from the "base" set
ii  gstreamer0.10-plugins-good:amd64             0.10.31-3+nmu4+b1                   amd64        GStreamer plugins from the "good" set
ii  gstreamer0.10-pulseaudio:amd64               0.10.31-3+nmu4+b1                   amd64        GStreamer plugin for PulseAudio
ii  gstreamer0.10-x:amd64                        0.10.36-2                           amd64        GStreamer plugins for X11 and Pango
ii  gstreamer1.0-clutter                         2.0.16-1                            amd64        Clutter PLugin for GStreamer 1.0
ii  gstreamer1.0-clutter-3.0                     3.0.6-1                             amd64        Clutter PLugin for GStreamer 1.0
ii  gstreamer1.0-libav:amd64                     1:1.2.3-dmo1                        amd64        FFmpeg plugin for GStreamer
ii  gstreamer1.0-nice:amd64                      0.1.7-1                             amd64        ICE library (GStreamer plugin)
ii  gstreamer1.0-plugins-bad:amd64               1.4.5-2+b1                          amd64        GStreamer plugins from the "bad" set
ii  gstreamer1.0-plugins-base:amd64              1.4.5-2                             amd64        GStreamer plugins from the "base" set
ii  gstreamer1.0-plugins-good:amd64              1.4.5-2+b1                          amd64        GStreamer plugins from the "good" set
ii  gstreamer1.0-plugins-ugly:amd64              1.4.5-2+b1                          amd64        GStreamer plugins from the "ugly" set
ii  gstreamer1.0-pulseaudio:amd64                1.4.5-2+b1                          amd64        GStreamer plugin for PulseAudio
ii  gstreamer1.0-x:amd64                         1.4.5-2                             amd64        GStreamer plugins for X11 and Pango
ii  libgstreamer-plugins-bad0.10-0:amd64         0.10.23-8                           amd64        GStreamer development files for libraries from the "bad" set
ii  libgstreamer-plugins-bad1.0-0:amd64          1.4.5-2+b1                          amd64        GStreamer development files for libraries from the "bad" set
ii  libgstreamer-plugins-base0.10-0:amd64        0.10.36-2                           amd64        GStreamer libraries from the "base" set
rc  libgstreamer-plugins-base0.10-0:i386         0.10.36-2                           i386         GStreamer libraries from the "base" set
ii  libgstreamer-plugins-base1.0-0:amd64         1.4.5-2                             amd64        GStreamer libraries from the "base" set
ii  libgstreamer0.10-0:amd64                     0.10.36-1.5                         amd64        Core GStreamer libraries and elements
rc  libgstreamer0.10-0:i386                      0.10.36-1.5                         i386         Core GStreamer libraries and elements
ii  libgstreamer1.0-0:amd64                      1.4.5-2                             amd64        Core GStreamer libraries and elements
ii  libreoffice-avmedia-backend-gstreamer        1:4.4.4-1                           amd64        GStreamer backend for LibreOffice
jj@legend ~ %

Comment 5

3 years ago
Yes, as it works with the build compiled by Mozilla, I close it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

3 years ago
Component: Untriaged → Audio/Video
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.