Register Firefox for Android as a handler for SVG files

RESOLVED FIXED in Firefox 58

Status

()

Firefox for Android
General
RESOLVED FIXED
3 years ago
5 months ago

People

(Reporter: Will Pittenger, Assigned: JanH)

Tracking

38 Branch
Firefox 58
Points:
---

Firefox Tracking Flags

(firefox58 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:25.6) Gecko/20150723 Firefox/31.9 PaleMoon/25.6.0
Build ID: 20150723184543

Steps to reproduce:

I use ES File Explorer.  I have both Firefox 38 and Firefox Beta 40.  But when I try to open a SVG file from ES, it doesn't have a way to open it.  It would appear neither version of Firefox is registered as able to open SVG files in Android.

You might want to check all the supported file types.


Actual results:

Firefox doesn't appear to be able to open local SVG files from a file browser.


Expected results:

File browsers should be able to use Firefox to open SVG files.
Created attachment 8641748 [details] [diff] [review]
bug1188927_svg.diff

If I'm correct (I'm not sure if that's all that has to be done, but on my phone it works), these two lines added in AndroidManifest do the trick.
Attachment #8641748 - Flags: review?(mark.finkle)
Comment on attachment 8641748 [details] [diff] [review]
bug1188927_svg.diff

LGTM, but I want Mike to double check this change.
Attachment #8641748 - Flags: review?(michael.l.comella)
Attachment #8641748 - Flags: review?(mark.finkle)
Attachment #8641748 - Flags: feedback+
Comment on attachment 8641748 [details] [diff] [review]
bug1188927_svg.diff

Review of attachment 8641748 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!

I haven't done much digging into how we handle opening Intents but because nothing has changed, I'd expect this to just work.
Attachment #8641748 - Flags: review?(michael.l.comella) → review+
(Assignee)

Comment 4

5 months ago
Seems like we forgot to actually check this in...
Assignee: nobody → jh+bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

5 months ago
The patch works with ES File Explorer, but not for the internal file manager on Android M, so this needs a little more investigation.
(Assignee)

Comment 6

5 months ago
... which is basically bug 1406903, as ES File Explorer uses file://, while the internal file manager uses content://

Comment 7

5 months ago
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4946d9cb418
Register Firefox for Android as a handler for SVG files. r=mcomella
(Assignee)

Comment 8

5 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4946d9cb4180e809ccc5587d97caf318e67e818
Bug 1188927 - Register Firefox for Android as a handler for SVG files. r=mcomella
https://hg.mozilla.org/mozilla-central/rev/f4946d9cb418
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
You need to log in before you can comment on or make changes to this bug.