If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

We checkerboard when scrolling Facebook all the time

RESOLVED DUPLICATE of bug 1256677

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1256677
2 years ago
2 years ago

People

(Reporter: Away for a while, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

(Reporter)

Description

2 years ago
http://people.mozilla.org/~bgirard/cleopatra/#report=e85a19cd298ab102a65fe9e1d5b794dda87cf04e
Whiteboard: gfx-noted
Blocks: 1013364
Here's a summary of the profile

22.4% in display list building
13.9% in BuildContainerLayerFor
4.4% in WillEndTransaction
37.7% in DrawPaintedLayer
 - 22% in CanvasBackgroundColor
 - 17.4% in Text
 - 13% in DisplayImage
 - 11% in BackgroundColor
13.6% in ValidateTile

Nothing suggests that we are painting particularly slowly. i.e having 22% of painting in CanvasBackgroundColor (basically memset) suggests that we are painting pretty fast.

I expect the big problems here are the non-paint overhead and the fact that we might be painting too much and not the right stuff.
Side note, this is on OS X. 22% spent in CanvasBackgroundColor still seems too slow. I see chunks of 8ms to paint a background color. That seems really bad. There is even one chunk that is 17 ms, which is a whole frame.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256677
You need to log in before you can comment on or make changes to this bug.