Closed Bug 118900 Opened 20 years ago Closed 14 years ago

Address book Print (or Print Preview) does not sort alphabetical (random order)

Categories

(MailNews Core :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9

People

(Reporter: nbaca, Unassigned)

References

Details

(Whiteboard: [adt3] nab-print, workaround comment 13)

Attachments

(1 file)

Trunk build 2002-01-08-03: WinMe

Overview: Print an address book and the cards do not appear in alphabetical 
order.

Steps to reproduce:
1. Select or create an address book with various entries. For instance:
- John Smith
- Zoi Jones
- Annie Blake
2. Select the address book from the directory pane
3. File|Print Address Book

Actual Results: The cards print in the order they were entered.
Expected Results: They should print in alphabetical order
- First Name, Last Name (should sort by first name?)
- Last Name, First Name (should sort by last name)
- Display Name (should sort by display name?)
Marking nsbeta1 so that when an adress book is printed, it prints in some type 
of order.
Keywords: nsbeta1
Whiteboard: nab-print
taking.  the fix for this is going to involve using the nsAbView when printing.
Assignee: racham → sspitzer
Status: NEW → ASSIGNED
Keywords: nsbeta1nsbeta1+
Priority: -- → P3
Blocks: 122274
Keywords: nsbeta1+nsbeta1-
Marking nsbeta1. It would be nice for the printed list to be in the same order
that is displayed in the Address Book window.
Keywords: nsbeta1-nsbeta1
Mail triage team: nsbeta1+/adt3
Keywords: nsbeta1nsbeta1+
Whiteboard: nab-print → [adt3] nab-print
Reassigning.
Assignee: sspitzer → cavin
Status: ASSIGNED → NEW
A linked problem is that address lists are printed unsorted.

More importantly lists are displayed unsorted when they are double-clicked to
bring up the list window.  

Similarly if a 'list' card is selected in the upper right pane the e-mail list
in the 'details' lower right pane is unsorted.

The list is however shown correctly sorted in the right upper pane if the 'list'
card is selected in the left pane.

Is this another bug or essentially the same one?
Target Milestone: --- → mozilla1.4beta
This bug was targetted for 1.4 beta, but isn't fixed in the latest build.  Is
there a new target?
Is there a targeted release in which to fix this bug?
I observe the same problem than the reporter using Mozilla 1.7 final, i.e. the
list is printed as it was entered in the address book instead of some
alphabetical order. This renders printing useless (try to find something in an
unordered list of several hundreds of addresses!!!).

This bug really needs attention (nothing has been done since 2002). Marking
blocking1.7.1? and 1.8a2? to get some attention from developers.
Flags: blocking1.8a2?
Flags: blocking1.7.1?
Flags: blocking1.8a2? → blocking1.8a2-
*** Bug 248789 has been marked as a duplicate of this bug. ***
*** Bug 261183 has been marked as a duplicate of this bug. ***
*** Bug 251236 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Flags: blocking1.7.5? → blocking1.7.5-
Work around...
- Create a new temp address book
- Select all cards in original address book.  Select view->show name as->last,
first.
- drag all cards to new address book.
- cards in new address book will be in order
- delete all entries in original address book
- drag all cards from temp address book to original address book
- delete temp address book.
Bill, thanks a lot for that tip, that one is great!
*** Bug 276575 has been marked as a duplicate of this bug. ***
While the workaround is nice for experienced users, explaining to my mom that
she can not print a sorted list without some mickey mouse roll call is very hard.

Can you print a sorted list in Outlook? What about Thunderbird?
Assignee: cavin → sspitzer
QA Contact: nbaca
Target Milestone: mozilla1.4beta → ---
(In reply to comment #16)
 
> Can you print a sorted list in Outlook? What about Thunderbird?

Doesn't work with Thunderbird (1.0 under Linux) for me.
*** Bug 286359 has been marked as a duplicate of this bug. ***
Assignee: sspitzer → mail
Whiteboard: [adt3] nab-print → [adt3] nab-print, workaround comment 13
*** Bug 290269 has been marked as a duplicate of this bug. ***
Assignee: mail → nobody
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
QA Contact: addressbook
This bug is still relevant in Thunderbird 1.0.6 on Windows XP SP2 machine.
This bug is still relevant in Thunderbird 1.5 beta2 win & linux
Use workaround from comment #13.
I have tidied the summary a bit here to make it easier to find.  I'm also
changng to all/all.
OS: Windows ME → All
Summary: Printing an address book and it is not sorted → Address book Print (or Print Preview) does not sort alphabetical (random order)
*** Bug 312717 has been marked as a duplicate of this bug. ***
You could fix this by using "nsAbView" I think...
*** Bug 364640 has been marked as a duplicate of this bug. ***
Seems a bit odd that although listed with last name, first, a person is not able to print the list  in that manner.  

Also when trying to print just the address book and not the card, it comes up as card for printing.

Takes up a lot of unnecessary paper, especially when traveling and needing your address book.

Would love to have this fixed.
Duplicate of this bug: 370806
Seems like a basic request to me - an alphabetical printed list!
Duplicate of this bug: 373613
I agree that the ability to print the address list alphabetically is a basic feature! I've just downloaded TBird 2.0.0.0 and was very surprised to see the bug unchanged.  Please take this as a "Yes" vote!  
(In reply to comment #30)
> I agree that the ability to print the address list alphabetically is a basic
> feature! I've just downloaded TBird 2.0.0.0 and was very surprised to see the
> bug unchanged.  Please take this as a "Yes" vote!  
> 

I agree: thunderbird has been bugged for 5 years!! Please fix it now!
Why has this 5 year old bug not been fixed in V2.0?

Ideally it would be nice to have print features ala Apple's Address Book which provides a number of ways to present printed records.
I agree...I cannot believe that we actually offer a product that can display the list in one order and yet ONLY print it in another order.  When I tell people that this is the case, they look at me like I have two heads--Please fix it--this is a YES vote!

Thanks!
this isn't just for the trunk version. maybe this makes this bug less visible: the bug is in the 2 version, too!!!
I looked at this code a little bit yesterday - it might be possible to change this print code to look up the current sort for the address book getting printed, create a view on it with that sort, and then print the cards in the view order. It depends on how general/modular/accessible the view code is, among other things.
David I have an idea that may tie in with how you plan to pre-process the address book data.  I thought of using a modal dialog where the user can select one of three sort orders.  That selection could then set the filter option applied during the pre-process.  This could give a print sort order with out altering the abook preference.

If you believe this should be a new enhancement I am willing to open a new bug for it.
As a senior who has little computer savvy, I wish my address book would be automatically alphabetized based upon the fist word in the name entered in the addsess book by me or my wife. No mental/computer gymnastics wanted! 
Attached patch wipSplinter Review
I'm going to try this out...it should be better than just using the card id as the sort order.
Attachment #278130 - Flags: superreview?(mscott)
Attachment #278130 - Flags: superreview?(mscott) → superreview+
we now sort by the generated name, before printing, so we respect the view | show name as preference w.r.t what order we print in, if I'm understanding the code correctly. So if you want to print by last name, you'd choose the display "last name, first" setting and then print.

This is fixed in nightly trunk builds and will be in Tb 3.0 - please don't expect it in 2.0 builds
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Easy work around to print in desired sort---

Export as .csv file which creates an Excel spreadsheet.  Manipulate data in Excel
however you wish.  Print Excel file for WYSIWYG results.
why does the status say resolved fixed.
It most certainly isn't fixed and it is an embarrassing bug to have.
For heaven's sake, fix it and the lame print format that wastes paper as well as coming out in an unusable order.
Patrick, so you've downloaded a trunk build and it didn't work for you? Or did you not read https://bugzilla.mozilla.org/show_bug.cgi?id=118900#c39 ?
Suggestion: print sort order is taken from the address book sort order used for display (default is name). Easy to use and understand + fairly standard way to do this.
Reading this thread I cannot understand why the status of this bug is "resolved".
Again, it's fixed in trunk builds, not 2.0x builds.
I'm new and untrained in computers. I would like the alphabetizing matter resolved because I will have to spend too much time looking for people randomly in the address book.  Make it high priority please. And how do I alphabetize my bookmarks?
David: any reason to keep this open? Were you planning on doing anything else here?
Magnus, the only reason to keep this open would be to make the sort be based on the current ab view sort, not just "Generated Name". But maybe it would make sense to open a new bug for that, and leave this one closed.
(In reply to comment #45)
> I'm new and untrained in computers. I would like the alphabetizing matter
> resolved because I will have to spend too much time looking for people randomly
> in the address book.  Make it high priority please. And how do I alphabetize my
> bookmarks?
> 

I agree here.  This is a problem that needs to be fixed immediately but it appears that this is an ongoing problem.  Maybe new help needs to be hired.
As you can see from the status, it's already fixed for thunderbird3/seamonkey2.
Priority: P3 → --
Target Milestone: --- → mozilla1.9
Product: Core → MailNews Core
It isn't "RESOLVED FIXED" until the code's distributed and working -- we still can't produce a usable ordered output, after 6 years!
The code is distributed and working. Try the latest beta:
ftp://ftp.mozilla.org/pub/thunderbird/releases/3.0b1/
http://www.seamonkey-project.org/releases/2.0a2
I need the feature but I'm afraid to go to a beta version.  According to the Thunderbird road map 3.o release was scheduled for first quarter 2008.  How come the delay?
(In reply to comment #52)
> I need the feature but I'm afraid to go to a beta version.  According to the
> Thunderbird road map 3.o release was scheduled for first quarter 2008.  How
> come the delay?

I'm pretty sure we have *never* stated or suggested a release of first quarter 2008. There is no delay on that date.
"We" didn't, mscott did, when he pushed it from "Q2 2007?" (a date he set while setting Tb2 release for "Late Fall 2006" in February 2006) to "Q1 2008?" in January 2007 in http://www.mozilla.org/projects/thunderbird/roadmap.html (which has the title "Mozilla Thunderbird 2 Roadmap", a hint that we aren't actually using that).

Dates are subject to change, Mozilla never has and never will expend a great deal of effort in continually updating expected dates of future releases since we're more interested in dates we can control and that affect us, like "when's the next code freeze, and when do I have to land these strings?", and the one thing that's absolutely certain is that the only effect of asking about release dates in old closed bugs is that you'll take up a little time from a few developers who don't *know* when a future release will happen, don't ultimately control when it will happen, but will then be a few minutes further behind on their part of it.
You need to log in before you can comment on or make changes to this bug.