Closed Bug 1189000 Opened 4 years ago Closed 4 years ago

SMTP Timeout in Thunderbird 38.1

Categories

(Thunderbird :: Untriaged, defect)

38 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1184488

People

(Reporter: Manderson, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Laptop A (Windows 8.1, Thunderbird 38.1) experienced Server Timed out message when sending a message. Prior to installing 38.1, this machine had no SMTP difficulties. Although the message referred to a timeout, it appeared less than 1 second after clicking on Send.

Laptop B (Windows 8.1, Thunderbird 31.7) could send e-mails with no difficulty.

All account settings on both machines were identical. As far as I could tell, the only material difference between the two laptops was the version of Thunderbird. So I updated Laptop B with Thunderbird 38.1.

After Laptop B was updated to Thunderbird 38.1, it could not send e-mails, received the identical Server Time out message.

Uninstalled Thunderbird 38.1 on Laptop B, installed 40. beta version - could not send e-mails, same message.

Uninstalled 40 beta on Laptop B, installed Thunderbird 31.3. E-mails can be sent again.

Uninstalled Thunderbird 38.1 on Laptop A, installed 31.3. E-mails can be sent again.

SMTP Server information:
grouse.arvixe.com
Port 587
Authentication method: Normal Password
Connection Security: STARTTLS

There is no Digital signing set up on the Thunderbird account for outgoing messages.




Actual results:

Reverting from Version 38.1 to 31.3 removed SMTP problem.

Conclusion: There's something in Thunderbird 38.1, carried over to Version 40 Beta, that is buggering up outgoing SMTP communication.


Expected results:

1. Versions 38.1 and 40 (beta) should not materially change the SMTP communication mechanisms.

2. The error message is misleading. Given the very short latency between clicking Send and seeing the message, it's clearly not a Time out problem. 

Feel free to contact me if you need more information.
Michael, does this help you?

(In reply to Magnus Melin from comment #1)
> Bug 1184488?
Flags: needinfo?(Manderson)
let's assume duplicate until Michael demonstrates otherwise
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(Manderson)
Resolution: --- → DUPLICATE
Duplicate of bug: 1184488
I can't tell you unambiguously if my bug is a duplicate. First, the error message I got (Server Time Out) was not referenced in any of the very detailed logs that are provided in the thread. Second, I have neither the time nor the expertise to go into Thunderbird guts and change what look like critical parameters.

However, I do have two comments.

First, if there is an authentication problem where there's a known work-around, Thunderbird really ought to tell the user what's going on and provide a non-technical way of fudging the parameters. I was doing the troubleshooting on my wife's computer, and there is no way she could have diagnosed the problem (Thunderbird changing its authentication protocol) and she would have had great difficulty in reverting to a previous version. Not everyone is a power user - if Thunderbird really wants to be a tool for the masses and a credible alternative to other e-mail client, you really can't allow it to suddenly stop working like that. And in the comments, it appears that you want to treat what most users will consider to be a flaw as a feature. 

So, I'll keep an eye on the comments to see if a subsequent release of Thunderbird deals with the issue or if enough e-mail server providers make whatever changes are required on their end. But we're going to upgrade to Windows 10 before the end of the year, and that has Mail again. If Thunderbird isn't working by then, we'll have no choice but to convert.

I must say how civilized the thread was. Many people contributing to forums like this feel free to indulge in remarks that are both childish and offensive - it was refreshing to see an adult, respectful exchange of information and views.
You need to log in before you can comment on or make changes to this bug.