Closed Bug 1189055 Opened 5 years ago Closed 1 year ago

Allow or require ICE TCP to go through an HTTP proxy when making connections

Categories

(Core :: WebRTC: Networking, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1569183
Tracking Status
firefox42 --- affected
Blocking Flags:

People

(Reporter: jesup, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: cisco-spark)

This would force use of TCP or TCP-TURN, and run the connection through the  configured HTTP or SOCKS proxy (if they can do this with UDP, great, but likely they can't).  This would add a measure of privacy to users who are attempting to use application-level proxies to hide their identity.  It's somewhat unclear how much additional privacy would be obtained, and dropping down the TCP for this is generally a bad idea, quality-wise.
backlog: --- → webRTC+
Rank: 25
Priority: -- → P2
Blocks: 1189167
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3
TURN-TCP already has the ability to go through HTTP proxies. But ICE TCP currently still ignores HTTP proxies, even though it could try to do the same trick.
Summary: Allow or require ICE to go through an HTTP proxy (using TCP) when making connections → Allow or require ICE TCP to go through an HTTP proxy when making connections
Keywords: cisco-spark
Depends on: 1569183

I think this may be fixed now that bug 1569183 has landed. Need to verify.

Flags: needinfo?(docfaraday)

This seems to be working, although about:webrtc is not marking these candidates as proxied, probably because these are always going to be prflx candidates, which set their address based on the STUN response instead of the socket.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(docfaraday)
Resolution: --- → DUPLICATE
Duplicate of bug: 1569183
You need to log in before you can comment on or make changes to this bug.