RSS items show incorrect URL

RESOLVED WONTFIX

Status

Thunderbird
Untriaged
RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: Jim C. Nasby, Unassigned)

Tracking

31 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8640745 [details]
rss20.xml

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Subscribe to an RSS feed that includes items which have <guid isPermaLink="true">. Example of this is attached, pulled from http://planet.postgresql.org/rss20.xml


Actual results:

Link displayed for post "Josh Berkus: unsafe UPSERT using WITH clauses" is <guid> element (tag:blogger.com,1999:blog-7476449567742726187.post-2774102237773628331) instead of <link> element (http://www.databasesoup.com/2015/07/unsafe-upsert-using-with-clauses.html).


Expected results:

Should have displayed contents of <link> element.

This was reported in bug 624535, which was marked as a duplicate of another bug. *This is still a problem for users*. Users don't care whether blogger.com is or isn't breaking RSS; they care that they can't get to the original article when using thunderbird.

Comment 1

2 years ago
Inform the publisher to read, understand, and implement the RSS2.0[1] spec.  In this case, it means setting isPermaLink="false" because, in fact, it's not a link.  The decision made on this long ago in Bug 624535 was correct.

[1] http://www.rssboard.org/rss-specification

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624535
(Reporter)

Comment 3

2 years ago
READ MY ORIGINAL REPORT:

"This was reported in bug 624535, which was marked as a duplicate of another bug. *This is still a problem for users*. Users don't care whether blogger.com is or isn't breaking RSS; they care that they can't get to the original article when using thunderbird."

So does the Thunderbird community not care about usability?

*Blogger.com* is NOT going to go fixing there stuff because Joe User claims that they're breaking the RSS spec, regardless of whether they are or not.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

2 years ago
Example from attachment of *google* (Blogger.com) doing this wrong:

<guid isPermaLink="true">tag:blogger.com,1999:blog-7476449567742726187.post-7814360070053193786</guid><pubDate>Tue, 28 Jul 2015 16:52:00 GMT</pubDate></item>

Comment 5

a year ago
It would be malpractice to add even one line of complexity or extra processing, on each refresh for each feed for each user, due to this feed's inability to follow spec.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.